Author Topic: Using dll Option in call Command  (Read 2257 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
Using dll Option in call Command
« on: February 09, 2017, 01:28:58 PM »
This forum article will show an example of how to use the "dll" option in the "call" command. With the "dll" option, we can use functions that exist in a .dll software file. We must include the .dll function in the SAPgui folder (e.g. "C:\Program Files (x86)\SAP\FrontEnd\SAPgui"). Depending on what function you are using, the parameters you pass will differ.

LiquidUI Code:

SAPLSMTR_NAVIGATION.E0100.sjs


// Use call command with DLL option to call a DLL function
call('alphanum', {"dll":"guixtstring", "In":"123","In.2":"6", "Out":"result"});
// RESULT should be "000123"
title("RESULT: "+result);