Author Topic: UserCatalog to differentiate Script Directories based on "CLIENT/USERS"  (Read 2399 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
GuiXT.SJS File:

=============================================
//WS Configuration File

license = [];
license.push({"license":"1-XX-XXXXX-0-7029-XXXXX-B67BC","data":{"company":"LIQUIDUI","systemid":["DEV","QAS","SBX","PRD"]}});

rfcuser = "rfcuser";
rfcunencryptedpassword = "rfcpassword";

rfcconnect = ["IFDATABASE=DEV, CLIENT=200, ASHOST=SAPDEV, SYSNR=00",
                     "IFDATABASE=QAS, CLIENT=300, ASHOST=SAPQAS, SYSNR=00"];

usercatalog="C:\\Folder\\SubFolder\\usercatalog.txt";  // Location of USERCATALOG file

OPENCONSOLE    =    0x00008000;
HIDECONSOLE    =    0x00000000;
TRACE_RFCCALL   =    0x10000000;

//TRACEFLAGS = HIDECONSOLE;
TRACEFLAGS = OPENCONSOLE;
=============================================

UserCatalog File:

=============================================
//----- User Configurations
// User groups:
// make correspondence to 1-4 script directories


M1         "C:\LiquidUI\Scripts\Directory"
M2         "\\network\Scripts\Directory"
M3         "SAPWR:Z.SAP_OBJECT"
XX         None

//User:
// make correspondence to one user group
// because there is no '*' user designation, only specified users are allowed.


200/USER1   M1
300/USER2   M2
200/USER3   M3
=============================================
« Last Edit: February 23, 2017, 11:14:16 AM by Rahul Gera »