Author Topic: Opening URL using a click of a pushbutton  (Read 3058 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
Opening URL using a click of a pushbutton
« on: March 15, 2017, 11:34:15 AM »
This example, is to OPEN a URL with the click of a Liquid UI Pushbutton using VIEW command

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
//////////////////////////////////////////////////////////////////////////////////////////////////////////////


Liquid UI Script:

pushbutton([TOOLBAR], "@01\\Qwww.liquid-ui.com@LiquidUI", "?", {"size":[1,25], "process":pm_launchpad, "using":{"l_layout":"htmlview", "l_html":"http://www.liquid-ui.com"}});
pushbutton([TOOLBAR], "@01\\Qwww.google.com@Google", "?", {"size":[1,25], "process":pm_launchpad, "using":{"l_layout":"htmlview", "l_html":"http://www.google.com"}});
pushbutton([TOOLBAR], "@01\\Qwww.yahoo.com@Yahoo", "?", {"size":[1,25], "process":pm_launchpad, "using":{"l_layout":"htmlview", "l_html":"http://www.yahoo.com"}});

function pm_launchpad(param){
                pm_layout = param.l_layout;
                pm_html = param.l_html;
}

if(pm_layout=="htmlview"){
                view([3,38], [30,193], "&V[pm_html]", {"floating":true});
                set("V[pm_layout]","");
                set("V[pm_html]","");
}
« Last Edit: March 15, 2017, 12:25:12 PM by Rahul Gera »