Author Topic: Selection of Table Rows using Liquid UI  (Read 2437 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Selection of Table Rows using Liquid UI
« on: June 22, 2017, 09:02:54 AM »
Purpose: 
Table rows selection is not recorded by the script recorder, code needs to be added manually to perform the table row selection with function.

Syntax:-
set("cell[Tablename,columnnumber,rownumber]","X");

Eg: selection of rows from "Select view(s)" screen of "MM01" transaction.

-> Start recording on designer, on "Create Material (Initial Screen)"
     Place "Industry Sector" as "Mechanical Engineering" ,  "Material Type" as "Finished product" and click on "Select View(s)" button from Toolbar.
-> On "Select View(s)" screen, select  views  "Basic Data 1", "Basic Data 2", "Sales: Sales Org. Data 1","MRP 1", "MRP 2" and "MRP 3" and click on green tick
     mark(continue)
-> You can see pop up "Organizational Levels"
-> Now stop the recording on Liquid UI Designer

 Designer Screen shows that no code was generated between onscreen 'SAPLMGMM.0070' and enter();

To make the function complete, following script needs to be added between "SAPLMGMM.0070" and enter();
  set("cell[Table,0,1]","X");  // selecting Basic Data 1
  set("cell[Table,0,2]","X");  // selecting Basic Data 2
  set("cell[Table,0,4]","X");  // selecting Sales: Sales Org. Data 1
  set("cell[Table,0,12]","X");  // selecting MRP 1
  set("cell[Table,0,13]","X"); // selecting MRP 2
  set("cell[Table,0,14]","X");  // selecting MRP 3


See attachments for more information