Author Topic: Determining fcode for the Keyboard Combinations  (Read 1918 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Determining fcode for the Keyboard Combinations
« on: July 10, 2017, 04:22:07 AM »
Purpose
To Determine fcode for Keyboard Combination.

Usage
Fcode: 'fcode' means the function code that is passed to application program by an event when the user chooses the pushbutton.
In Liquid UI, we can use fcodes In liquid UI  pushbuttons to perform a particular functionality and also in onUIEvents to trigger function when an event of that fcode occurs.

Usage of fcode with pushbutton:
pushbutton([3,144], "SAVE", "/11");
/11 - is the fcode for save

Usage of fcode with onUIEvents:
onUIEvents["/11"] = {"fcode":z_save};
/11 - fcode for save.
Z_save - liquidui function executed on save event.

In SAP, we find this function keys assigned to buttons in the form of function keys such as F1,F2,F3… CTRL and SHIFT.
We can determine fcode for these keyboard combinations to use them with liquid UI as below.

F1 = 1      F2 = 2      F3 = 3      F4 = 4
F5 = 5      F6 = 6      F7 = 7      F8 = 8
F9 = 9      F10 = 10   F11 = 11   F12 = 12
SHIFT = 12   CTRL = 24

To find fcode for keyboard combination for (CTRL + F1)
CTRL + F1 = /25
24 + 1 =25

To find the keyboard combination for (/37)
/37 = CTRL + SHIFT + F1
37 = 24 + 12 + 1

Note: fcode for events is also generated while recording using designer.



« Last Edit: August 02, 2017, 11:01:43 PM by sarvani.kusuri@guixt.com »