Author Topic: Liquid UI - "box" command  (Read 1881 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Liquid UI - "box" command
« on: September 19, 2017, 02:51:15 PM »
Purpose:
The box command is used to create boxes around groups of elements.
The box command enables users to create boxes for either single screen element or a group of elements.
This command is very useful when a user wishes to create a cleaner interface and enclose SAP elements into a single group.

The syntax is as follows:
   box([row_start,column_start],[row_end,column_end], "Field label");
   
Options:
The box command takes the one option called "offset".
This option specifies by how many rows and columns the box will be offset.
Offset is relative to the screen margin so we need to specify by how much the box will be offset from the screen margin.

The syntax is as follows:
   box( {"offset":[row_start,column_start]}, {"offset":[row_end,column_end]}, "Label");

Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPMV45A.E0101.sjs       // VA01 transaction
----------------------------------------------------------------------------------------------------------------------------------------------
// Creating custom group box
box([11,0], [15,61], "Custom Groupbox");


See attachments for code samples!
« Last Edit: September 19, 2017, 03:18:17 PM by Benjamin Dasari »