Author Topic: Using View Command with SAP URLs  (Read 2283 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Using View Command with SAP URLs
« on: October 26, 2017, 09:17:07 AM »
Purpose:
Using view command to display and execute SAP URLs.

Usage:
View command can be used to populate the data from a HTML page into a SAP screen. Both inputsets and process execution are possible.
An inputset is defined as a set of values to be input into SAP. SAPurls are displayed using the view command and appear within a SAP screen. In this case we are displaying them in the VA01 screen. 

Below example demonstrates the using of SAP URLs with view command on "VA01" initial screen.
Liquid UI Code:
////////////////////////// SAPMV45A.E0101.sjs //////////////////////////////

view([0,84],[24,131], "SAPLinks.htm");

////////////////////////// SAPLIQS0.E0100 ///////////////////////////////////
function executeIw21( ) {
onscreen 'SAPLIQ50.0100' 
set("F[Notification type]", "M1");
enter( );
 }

HTML Code
//////////////////////////////  SAPLinks.htm //////////////////////////////

<a href="SAP://OrderType:OR">Launch VA01[/url]
  // assign value 'OR' to order type field
 
<a href="SAP://OK:/nMM01">Launch MM01[/url]
// navigates to MM01 t-code
 
//navigates to IW21 transaction and executes function executeIw21
<a href="SAP://OK:/nIW21, process=executeIw21">Launch IW21  1[/url]

 
//navigates to MM01 t-code by click on image displayed
<a href="SAP://OK:/nmm01"> <img src="mm01.gif" alt="Launch MM01" width="60" height="20"><BR> [/url]

//navigates to IW21 t-code by click on image displayed
<a href="SAP://OK:/niw21"> <img src="iw21.gif" alt="Launch IW21" width="60" height="20"><BR> [/url]
 
//displays button and executes function launchva01 on click
<form> <input type="button"  value="Launch VA01 " onclick="launchva01()" />
</form>

//displays button and executes function launchmm01 on click
<form> <input type="button"  value="Launch MM01 " onclick="launchmm01()" />
</form>

//displays button and executes function launchiw21  on click
<form> <input type="button"  value="Launch IW21 " onclick="launchiw21()" />
</form>
 
// javascript functions under <script> tags
<script>
function launchva01() {
   window.location = "SAP:// OrderType:OR;/OK";
}

function launchmm01() {
   window.location = "SAP://OK:/ nMM01";
}

function launchiw21() { 
   window.location = "SAP://OK:/ niw21";
}
</script>

See attachment for more information and screenshots
« Last Edit: March 02, 2018, 04:22:27 AM by sarvani.kusuri@guixt.com »