Author Topic: Triggering "Object for Services" Functionality with Enter Command  (Read 2724 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Purpose:
To perform "Object for Services" functionality by passing ActiveX parameter to enter command

Liquid UI Script
/////////////////////////////// SAPMF05A.E1100.sjs ///////////////////////////////

pushbutton([TOOLBAR], "Store Business Doc", {"process":objServicesExecute});
function objServicesExecute()
{
     onscreen 'SAPMF05A.1100'
          enter({"control":"GOSCONTAINERCTRL.Toolbar", "item":"%GOS_TOOLBOX;381;328", "event":2});
     onscreen 'SAPMF05A.1100'
          enter({"control":"GOSCONTAINERCTRL.Toolbar", "item":"%GOS_ARL_LINK","event":1});
}

After entering the above code in the script file 'SAPMF05A.E1100.sjs' for the 'FV60' transaction.
Save your changes and launch and login to SAPGUI and follow below steps to demonstrate functionality.

  - Goto 'FBV2' transaction and click on 'Document List(F5)' button on the toolbar.
  - On screen "List of parked Documents", enter values for an existing document to edit.
     Sample data:
       . company code - 0001
       . Document Number- 1900000338
       . Fiscal year - 2012
       Note: above data may not be similar please enter existing data.
  - Once entered values click on 'Execute(F8)' on toolbar.
  - On screen "Changed Parked Documents: List", click on 'Choose(F2)' first button on toolbar.
  - You are now in the 'FV60' transaction and the script you previously created will take effect.
     Click on GUIXT created toolbar button 'Store Business Doc'.
  - Clicking the 'Store Business Doc' button will execute the WS function 'objServicesExecute' and will send the ActiveX services
     for Object menu which will trigger the action to store a business document.
  - If the operation completes successfully, you will see the 'Archive from Frontend' window appear.

See attachment for more information and screenshots