Author Topic: Tab Command to move the Cursor to desired field.  (Read 2936 times)

Ashfaq Ahmed

  • Administrator
  • Newbie
  • *****
  • Posts: 29
    • View Profile
Tab Command to move the Cursor to desired field.
« on: July 07, 2020, 02:49:54 AM »
Purpose:

To move the cursor to the desired field when a Tab is Pressed.

Syntax:

tab("[From-Screen-Field]","[To-Screen-Field]");

Example: Below example, explains the navigation of "Cursor", when a tab is performed, with Liquid UI script tab command defined.

when a tab is performed, while cursor is stationed in "PO date" inputfield, the cursor focus moves to "Deliver.Plant" inputfield and then when the tab is performed again from "Deliver.Plant" inputfield cursor focus is moved to "Payment Card" inputfield.
Then again when the tab is performed, when the cursor focus is on "Card Verif.Code" inputfield, the cursor focus shifts to "All Items Table Item Column First Row".


1. Create a script file "SAPMV45A.E4001.sjs" with the following code and save it in your ws scripts directory as configured in "guixt.sjs" file.

       tab("F[PO date]","F[Deliver.Plant]");
       tab("F[Deliver.Plant]","F[Payment Card]");
       tab("F[Card Verif.Code]","cell[All items,Item,1]");


2. Navigate to the transaction VA01. Input "Order type" as "OR" and hit enter.
3. Set cursor focus on "PO date" field, by clicking inside the inputfield, now press "Tab" on the keyboard, now the cursor moves to the "Deliver.Plant" inputfield, when the Tab is pressed again, the cursor will move from "Deliver.Plant" inputfield to "Payment terms" inputfield.
And so, when the Tab is Pressed while cursor focus is on "Card Verif.Code" inputfield the cursor will move to the "All Items Table Item column First row".
« Last Edit: July 21, 2020, 12:14:07 PM by Rahul Gera »