Using Your Liquid UI Products > WS aka Web Scripts (Attended RPA for SAP)

LiquidUI: System Variable - _transaction

(1/1)

chirag.amin@guixt.com:
This is an example of using the system variable "_transaction". This system variable holds a string value of what transaction is being used. Many times, the same screen name is used for different transactions. This variable is very useful when you want a script to run only for a certain transaction.

LiquidUI Code


//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// If the transaction is VA02, execute the following
if(_transaction == "VA02"){
   
   // edit the title
   title("ON VA02");
   // delete the pushbuttons we don't want to for VA02
   del("P[Sales]");
   del("P[Item overview]");
   del("P[Ordering party");
   del("P[Orders]");

}

// If the transaction is VA02, execture the following
else if(_transaction == "VA03"){
   
   // edit the title
   title("ON VA03");
   // delete the groupbox we dont want
   del("G[Search Criteria]");
   
}

Navigation

[0] Message Index

Go to full version