Author Topic: LiquidUI: Load Command  (Read 2062 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: Load Command
« on: February 08, 2016, 11:46:12 AM »
The load command is used to load an external file. Once the file is loaded, anything included in the file will be available for global use in WS scripts.

LiquidUI Code:

SAPLSMTR_NAVIGATION.E0100.sjs

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// load the file functions.sjs
load("functions.sjs");
// clear the screen
del("X[IMAGE_CONTAINER]");
// Run the function that is defined in the other file
createTexts();


functions.sjs

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// a function to create
function createTexts()
{
   println("in here");
   for(var i=0; i<10; i++){
      text([0+i,0], "Print Something");   
   }
}

See attachments..