Author Topic: LiquidUI: Message Command  (Read 2062 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: Message Command
« on: February 09, 2016, 10:05:34 AM »
The message command can display messages on SAP screens. Displaying messages may be useful for either educational or troubleshooting purposes.

LiquidUI Code:

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////


// prototype for string to trim blank spaces
String.prototype.trim = function() {
   return this.replace(/^\s+|\s+$/g,"");
}

// display a message welcoming the user with a success symbol
message("S:Welcome "+_user.trim()+"!");
// display a message welcoming the user with an error symbol
message("E:Welcome "+_user.trim()+"!");
// display a message welcoming the user with a warning symbol
message("W:Welcome "+_user.trim()+"!");

See attachments..