Author Topic: LiquidUI: "numerical" and "date" options  (Read 1988 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: "numerical" and "date" options
« on: February 16, 2016, 11:38:06 AM »
Two very useful options available for the input field command are "numerical" and "date". The "numerical" option restricts the user from entering any letters into the field. The "date" option makes the F4 key bring up a calendar for the search help. These options are helpful in cutting down invalid input when the fields are meant only for numerical values or more specifically, dates.

LiquidUI Code:

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// For this inputfield, the numerical and date options will be set to true
inputfield([0,0],"Enter today's date:", [0,22], {"size":10, "name":"z_current_date", "numerical":true, "date":true});



See attachments..
« Last Edit: February 16, 2016, 11:41:12 AM by chirag.amin@guixt.com »