Using Your Liquid UI Products > WS aka Web Scripts (Attended RPA for SAP)

Copy File Contents to Clipboard

(1/1)

Benjamin Dasari:
Purpose:
To copy the contents of a text file to the clipboard by executing a function on UIEvent/s.


Liquid UI Code:

// SAPLSMTR_NAVIGATION.E0100.sjs
// User Interface - SAP Easy Access Screen
pushbutton([TOOLBAR],'Copy to Clipboard', '?', {'process':copyClipBoard,'size':[1,20]})

// Copies the contents of the file to the clipboard
// Need to have webscript.dll v175 or later
function copyClipBoard() {
   // Examples:
   // system.ShellExecute('iexplore.exe','http://www.guixt.com');                       // Opens Web Browser with specified link
   // system.ShellExecute('notepad.exe');                                                            // Opens Notepad
   // system.ShellExecute('notepad.exe', 'C:\\guixt\\scripts\\filename.txt');      // Opens Specified File in Notepad
   system.ShellExecute('cmd.exe', '/C type c:\\guixt\\scripts\\test.txt|clip');
}


See attachments for code samples!

Navigation

[0] Message Index

Go to full version