Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Sai Siddhartha on December 21, 2017, 06:47:35 AM

Title: Data Dependent Views
Post by: Sai Siddhartha on December 21, 2017, 06:47:35 AM
Purpose:
Data dependent viewing ability enables user might have a number of files, named with different names.
If a user enters a value in a given inputfield the file linked to that field would be displayed.

Usage:
This functionality allows you to use variables to specify the file names.
To demonstrate this functionality, please do the following.
1.   Create several files, naming them 'img0005001','img0005002','img0005003'.
2.   Enter below code in file ''SAPSLMTR_NAVIGATION.E0100.sjs'.

Liquid UI Code
/////////////////////////// 'SAPSLMTR_NAVIGATION.E0100.sjs' //////////////////////////

del("X[IMAGE_CONTAINER]");  // deletes image
inputfield([1,5], "Material Number", [1, 31], {"name":"z_matno", "size":20});  //field to specify file name to open
pushbutton([TOOLBAR], "View Files", {"process":z_view});   // executes function on click

function z_view() {
     view("img&V[z_matno].txt");  // view command take value field variable
}

See attachment for more information and screenshots