Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Rahul Gera

Pages: 1 ... 3 4 [5] 6
61
Purpose: To dedicate System Keys for Liquid UI Mobile App

Usage Scenario:
1. When a FKey (F1...F12) is pressed on the Keypad, instead of Operating System function, dedicated Fkey action of SAP needs to take priority.

Pre-Requisites:
1. Active Sync or Windows Mobile Device Center software on Windows PC.
2. Liquid UI executable and the provided Liquid UI Mobile license in one folder (SynMobile).
3. MyMobiler software installed on PC (optional).

Steps to Map the Windows O.S. Keys on Handheld to Liquid UI Mobile Software:
Step 1: Connect the Handheld to computer (PC), so that the SynMobile Folder can be placed or accessed.
Step 2: If SynMobile Folder is on the Handheld, then Copy and Paste the Folder to PC.
Step 3: Open GuiXTMobile.sy3 (License File) that was provided or was copied on to PC.
Step 4: Enter the line UseOSKeysMapping=<binary> underneath/after LConnectCount entry.
            - binary specifies the mapping of system keys.
            - By default UseOSKeysMapping is set to 1.
            - For dedicated use of these keys, by Liquid UI, set UseOSKeysMapping=0.
Step 5: Save the file GuiXTMobile.sy3 in SynMobile Folder and place the folder on the handheld device.
Step 6: Close Liquid UI for Mobile application and start again to verify the change in using system keys.

62
Purpose: Using different Font sizes on Liquid UI Mobile Client.

Pre-Requisites:
1. Active Sync or Windows Mobile Device Center software on Windows PC.
2. Liquid UI executable and the provided Liquid UI Mobile license in one folder (SynMobile).
3. MyMobiler software installed on PC (optional).

Steps to change Font Sizes on Liquid UI Mobile Software:
Step 1: Connect the Handheld to computer (PC), so that the SynMobile Folder can be placed or accessed.
Step 2: If SynMobile Folder is on the Handheld, then Copy and Paste the Folder to PC.
Step 3: Open GuiXTMobile.sy3 (License File) that was provided or was copied on to PC.
Step 4: Enter the line UseFontSizeInPoint=<numeric> underneath LConnectCount entry.
            - numeric specifies the point size of the onscreen font.
            - The size range is from 6-10 and the default is 8.5.
Step 5: Save the file GuiXTMobile.sy3 in SynMobile Folder and place the folder on the handheld device.
Step 6: Close Liquid UI for Mobile application and start again to verify the change in Font Sizes.


63
Perquisites:
1.   Installation of Liquid UI WebServer.
2.   Configure Liquid UI WebServer to connect to SAP R/3.
3.   Browser Client to display Login screen for SAP R/3.

Steps to select a different theme for Liquid UI Web Server:
Step 1: Execute RunGuiXT4Web.bat file in WebServer Installed folder, to start Liquid UI WebServer.
Step 2: Connect on the browser to the SAP R/3 specified in Config.js
             eg:http://<WebServer>:<portnumber>/guixt4web/logon.gsp
Step 3: Login screen appears on the browser with current skin (Theme).
Step 4: Open Config.js file, in WebServer installed folder.
             C:\Program Files\Synactive Inc\Webserver              (or)
             C:\Program Files (x86)\Synactive Inc\Webserver  --> 32Bit WebServer on 64Bit O.S Machine

Step 5: Current Theme (Style Key) is specified in const DEFAULT_STYLE_KEY = 'f35'; statement.
Step 6: Few other Style keys are provided, in Config.js under,
const   STYLE_CONFIG = {"classic":"classic","2010":"2010","liquid":"liquid","f35":"f35","ui5":"ui5"} array to choose.
Step 7: Change const DEFAULT_STYLE_KEY = 'f35'; statement to const DEFAULT_STYLE_KEY = 'ui5';.
              (Other Style Keys can also be used...'classic','2010' and 'liquid').
Step 8: Re-Start RunGuiXT4Web.bat file.
Step 9: Connect on the browser to the SAP R/3.
Step10: The Browser Skin (Theme) would be changed.
.
.
.
.
see the attachment for more details

64
Perquisites:
1.   Installation of Liquid UI app on the Android device.
2.   Installation of Liquid UI License.
3.   Connection to SAP R/3 Server (even demo.guixt.com can be used).

Steps to select a different theme for Liquid UI Android:
Step 1: Login to the SAP R/3 connection.
Step 2: Tap on the left top corner of the screen on three horizontal lines, next to Liquid UI Logo.
Step 3: A side menu bar slides in, with SAP R/3 and other details.
Step 4: Scroll down and under App settings section,  Tap on Home Screen.
Step 5: On the Connection list screen, Tap the left top corner of the screen on three horizontal lines.
Step 6: From the side menu, Tap on App Settings.
Step 7: On the Insider screen, scroll to the bottom, to find Theme section with the current theme name displayed.
Step 8: Tap on current theme entry.
Step 9: And a drop down list with other themes show up.
Step 10: Select any other theme from the drop down list.
Step 11: The new theme is applied on to the Liquid UI Android screens.
.
.
.
.
see the attachment for more details

65
Perquisites:
1.   Installation of Liquid UI app on the iOS device.
2.   Installation of Liquid UI License.
3.   Connection to SAP R/3 Server (even demo.guixt.com can be used).

Steps to select a different theme for Liquid UI iOS:
Step 1: Login to the SAP R/3 connection.
Step 2: Select the right bottom corner of the screen @ SAP Server Name
Step 3: A bubble with a list of entries pop's up.
Step 4: Tap on "Theme Selection" entry.
Step 5: Another pop up appears with a dropdown list of different themes.
             Selected / highlighted is the current theme.
Step 6: Select any other theme from the dropdown list, and Tap on OK.
Step 7: The new theme is applied on to the Liquid UI iOS screens.
.
.
.
.
see the attachment for more details

66
SAPgui actions can be recorder using Liquid UI Designer, and can be used in a function or in a process associated with a pushbutton or onUIEvent.

Pre-requisites:
1. SAPgui installed and properly configured and connected to SAP R/3 (sandbox).
2. Liquid UI Designer installed and properly configured with SAPgui.
3. Liquid UI Active on current user machine.

Steps to Initiate Recording on Liquid UI Designer:
Step 1: Login to sandbox using SAPgui.
Step 2: Navigate to the desired Tcode, where the actions need to be recorded.
Step 3: Execute Designer.exe, from Liquid UI Designer folder.
Step 4: Click on the RED/record button on Liquid UI Designer
            (Recording of SAPgui actions has been started, with Designer screen being all blank)
Step 5: Navigate to SAPgui screen and continue with performing actions on SAPgui window.
Step 6: After all the actions are complete, navigate to Liquid UI Designer, only to find the actions recorded.
            (each and every click, entry, and navigation is recorded, between onscreen and enter block)
Step 7: To complete/STOP recording, Click again on the same RED/record button, that is in Step 4.

Note: Actions that are performed on ALV Grid Controls are not recorded.
.
.
.
.
See attachment for screenshots

67
Purpose: Download and Installation of Liquid UI for Desktop

Environment:
• Windows XP, Vista, Windows 7 and above.
• Windows Server 2003, 2008 and above.
• System must meet SAP 7.10 system requirements.

Download: http://updates.guixt.com/secured/LiquidUISetup.exe

Pre-Requisites:
• Back up of existing GuiXT Files - guixt.dll, guixt.exe and guixt.ini (if there is any).
   -   Location of GuiXT Files
       o   C:\Program Files\SAP\FrontEnd\SAPgui              32Bit Windows O.S
       o   C:\Program Files(x86)\SAP\FrontEnd\SAPgui     64Bit Windows O.S
• All Instances of SAPgui should be shut off completely, including the SAP Logon Pad.
• Administrative Privileges to Install Setup files and Access to Modify Root folder (C:\)

Installation of Liquid UI for Desktop:
1. Download and save the setup.exe file from above to the target system's hard drive.
    -   The file is named 'LiquidUISetup.exe'
2. Right click on 'LiquidUISetup.exe' and select "Run as Administrator".
3. Follow the installation wizard and complete the installation process.


see the attachment for corresponding screenshots

68
Purpose: To Download, Install and Execute Liquid UI for Mobile on HandHeld RF Guns.

Download: http://updates.guixt.com/secured/LiquidUIMobile.zip

Installation of Liquid UI Mobile on a Handheld Device:
GuiXT Mobile does not employ an install wizard, so the installation process will be performed manually.
To install the Mobile client on a supported handheld device, please do the following.
         Note: You must have Microsoft ActiveSync / Windows Mobile Device Center (MAS/WMDC) installed in order to complete the installation.
                    MAS/WMDC can be obtained from,
                                        Windows 64Bit Machine: www.microsoft.com
                                        Windows 32Bit Machine: www.microsoft.com.

1. Download and save the zip file from above to the target system's hard drive. The file is named 'LiquidUIMobile.zip' and contains the following files:
Mob-CE.exe This file is used for certain specific installations based on Windows Mobile O.S --> CE.
          You will not use this file unless otherwise instructed by a Synactive Support representative.
Mob-CEx86.exe This file is used for certain specific installations based on Windows Mobile O.S --> CE 32Bit.
          You will not use this file unless otherwise instructed by a Synactive Support representative.
MobPPC03up.exe This file is used for certain specific installations based on Windows Mobile O.S --> Embedded.
          You will not use this file unless otherwise instructed by a Synactive Support representative.
Mob-SymbolCE.exe This file is used for certain specific installations based on Windows Mobile O.S and Device Type --> Symbol CE Devices.
          You will not use this file unless otherwise instructed by a Synactive Support representative.
2. Unzip the LiquidUI_Mobile.zip to a location of your choice.
3. Launch MAS/WMDC and connect to your device. When the device is connected, click the Explore button in MAS/WMDC and navigate to the Program Files directory on the device.
4. In the Program Files directory, create a new folder called 'Synactive' and then create a 'LiquidUIMobile' sub folder.
5. Use MAS/WMDC to copy the correct versions of both the 'MobXXXX.exe' and the 'license file' to the new 'LiquidUIMobile' directory on the device.
6. Create a shortcut, name it 'LUIMobile' and paste it into the device's \Windows\Start Menus\Programs directory.
7. The entry for LiquidUI Mobile should be visible in the device's Start > Programs directory.
    Note: However, do not launch the application. Launching GuiXT Mobile before the license is installed will result in an error message.
8. Proceed to the license installation section and install the license.

License Installation of Liquid UI Mobile on a Handheld Device:
To generate a trial license, Synactive will require the SAP installation number and SAP System ID.
Please follow the steps below to provide this information:
1. Login to your SAP GUI from the desktop.
2. Click on the System menu on the top right.
3. Select the Status option from the dropdown menu.
4. Please send us a screenshot of the Status Windows that pops up

Installation of generated Liquid UI License:

Once your license is approved, Synactive will send it to you as an email attachment.
To install it, please do the following.
1. Copy the file you receive from Synactive to the LiquidUIMobile directory on the device where the application resides, using MAS/WMDC.
    Note: License (GuiXT Mobile.sy3) and the executable file (Mobxxxx.exe) are to be placed in the same Folder.
2. Go to Start > Programs > LUIMobile.
3. An empty Liquid UI Mobile logon pad will appear.
4. Click New to create a new connection.
5. Enter the appropriate information for a new connection.


see the attachment for corresponding screenshots

69
Pre-requisites:
1. The Liquid UI license should be applied
2. The Liquid UI for Android app need to be completely closed on the device.

Steps to Enable Logs on Liquid UI for Android
1. Open the Liquid UI Android and click on "App Settings"
2. Click on "Turn Trace On" button to enable Liquid UI Android logging.
3. Continue with Liquid UI App execution.
4. After the Liquid UI App Crash happens, please follow the below steps to retrieve the logs.

Retrieve and email generated logs:
1. After the process and upon receiving the error, click on the "Turn Trace Off"? button
2. A pop up screen appears.
3. Add the necessary Comments and click on YES button
4. This should send an email with the log files attached.
5. A toast appears on Android Screen, specifying logs sent (dispatched)
.
.
.
.
see the attachment

70
Pre-requisites:
1. The Liquid UI license should be applied
2. The Liquid UI for iOS app need to be completely closed on the device.

Steps to Enable Logs on Liquid UI for iOS:
1. Open the iOS settings and click on "GuiXT LiquidUI"
2. Click on "Logging" button to enable Liquid UI logging.

Retrieve and email generated logs:
1. After completing the process and upon receiving the error, click on the Settings button on the LiquidUI screen.
2. Click on "About" button.
3. Click on "Support" button
4. This should open up an email with the log files attached.
5. Please address the email to support@guixt.com
.
.
.
.
see the attachments

71
Pre-Requisites:
1. Liquid UI app should be completely closed on the iOS device.
2. Liquid UI license should be in the email that is configured in the Native email app of the iOS device.

Steps to Install Liquid UI license on an iOS device:
1. Close the Liquid UI app on the iOS device.
2. Open the Liquid UI license from the Native Mail app of the iOS device.
3. Open the email containing the license.
4. Click and Hold on the Liquid UI license. A pop up appears prompting to select one of the options.
5. Select the option Copy to "GuiXT Liquid UI"
6. The License is installed and the "Add Connection" screen appears.
7. Click on "Add Connection" and create a SAP Logon connection to SAP server similar to SAPgui.
8. Save the connection and Click on the connection.
9. Login screen with username and password appears.
10. Click on the Wrench icon
11. System Menu and Context Menu appears
12. Click on About in the drop down menu
13. A pop up opens verifying the validity of the license
.
.
.
.
see the attachment

72
Pre-Requisites:
1. Liquid UI app should be completely closed on the Android device.
2. Liquid UI license should be in the email that is configured in the Native email app of the Android device.

Steps to Install Liquid UI license on an Android device
1. Open the mail which contains the license attachment on you Android device.
     Note: Please use the native mail application instead of using a browser application.
2. Click on the .sy3 attachment and start to download the license file.
3. Once the license is downloaded, click on the attachment.
4. It will automatically open up the LiquidUI application and have the license imported.
     Note: You should see a message as below after the license is imported.
5. For validation of License, click "Insider" at menu screen then scroll down to license information.
.
.
.
.
please see the attachment

73
Pre-Requisites:
Installation of iTunes on the Windows Device

Steps to follow in obtaining UDID for the iOS Device:

1. Connect iOS device to iTunes and on "Summary" screen the "Serial Number" is visible.
2. Click on the "Serial Number" and then "Identifier (UDID)" of the iOS device is shown.
3. Note down the 40 character UDID which doesn't start with FFFFFF.....


(please see the attachment)

74
Purpose of using a Centralized GuiXT.SJS(configuration) file:
Forbid User(s) to access or change Liquid UI for Desktop or Liquid UI Server configuration accidentally.

Sample Local GuiXT.SJS file:
===================================================================
rfcuser="<rfc_user>";
rfcunencrytpedpassword="<rfc_unencrypted_password>";
//rfcencrytpedpassword="<rfc_encrypted_password>";

rfcconnect =    ["IFDATABASE=DEV, LANG=E, CLIENT=100, ASHOST=SAPECCDEV, SYSNR=00,
                         "IFDATABASE=QAS, LANG=E, CLIENT=200, ASHOST=SAPECCQAS, SYSNR=00,
                         "IFDATABASE=PRD, LANG=E, CLIENT=300, ASHOST=SAPECCPRD, SYSNR=00];

// SWITCHTO command is used to Switch the Configuration File to the Centralized Configuration File

switchto = ["SAPWR:ZGXT.GUIXT.SJS"];                                          // Web Repository Deployment
// switchto = ["C:\\GuiXT\\Config\\GuiXT.SJS"];                              // Local Folder Deployment
// switchto = ["\\\\Network\\Subfolders\\Config\\GuiXTWR.SJS"];  // Network Deployment[/b]

const FLG_HIDE_CONSOLE = 0x00000000;
const FLG_RFCDIRECT_CONSOLE = 0x10008000;
const FLG_DISPLAY_CONSOLE = 0x00008000;


// TRACEFLAGS=FLG_DISPLAY_CONSOLE;
TRACEFLAGS=FLG_HIDE_CONSOLE;
===================================================================


Sample Centralized GuiXT.SJS file:
===================================================================
directory1 = "SAPWR:ZGXT";

license = [];
license.push({"license":"1-2012-36565-0-6874-1978B-563C9","data":{"company":"Synactive","systemid":["DEV","QAS"]}});
license.push({"license":"1-2012-36565-0-6874-1978B-563C9","data":{"company":"Synactive","systemid":["PRD"]}});

enablesystem = ["DEV","QAS","PRD"];

replication = "yes";                                      //File Caching Enabled

const FLG_RFCDIRECT_CONSOLE = 0x10008000;
const FLG_DISPLAY_CONSOLE = 0x00008000;
const FLG_HIDE_CONSOLE = 0x00000000;

TRACEFLAGS = FLG_HIDE_CONSOLE;
// TRACEFLAGS = FLG_REDIRECT_CONSOLE;
//TRACEFLAGS = FLG_DISPLAY_CONSOLE;

===================================================================

75
Environment:
Liquid UI WebServer Version: 1.1.82.0 and above.

Purpose of SSL in Liquid UI WebServer:
For User to access Liquid UI WebServer securely.
The SAP application server itself communicates with the Liquid UI WebServer via DIAG so no encryption is required.
To TURN-ON SSL, on Liquid UI WebServer, one Server Certificate, and one Private Key is required.
These Certificate and Key are specified, along with location path in Config.js.

Sample CONFIG.JS:

const USING_SSL = true;                                        // Change the value from 'USING_SSL' from 'false' to 'true'
const DEF_WEBPORTSSL_BASE = "443";
const DEF_WEBPORTSSL_IDX  = "0";
const DEF_SSL_PARAPHRASE  = "Alana888";
const DEF_SSL_KEYFILE     = "server.key";
const DEF_SSL_CERTIFICATE = "server.crt";

Pages: 1 ... 3 4 [5] 6