Liquid UI Forum

Using Your Liquid UI Products => Desktop Product (SAP GUI, Excel and PDF) => Topic started by: Rahul Gera on June 12, 2017, 10:56:04 AM

Title: Switching Configuration to a Centralized GuiXT.SJS file
Post by: Rahul Gera on June 12, 2017, 10:56:04 AM
Purpose of using a Centralized GuiXT.SJS(configuration) file:
Forbid User(s) to access or change Liquid UI for Desktop or Liquid UI Server configuration accidentally.

Sample Local GuiXT.SJS file:
===================================================================
rfcuser="<rfc_user>";
rfcunencrytpedpassword="<rfc_unencrypted_password>";
//rfcencrytpedpassword="<rfc_encrypted_password>";

rfcconnect =    ["IFDATABASE=DEV, LANG=E, CLIENT=100, ASHOST=SAPECCDEV, SYSNR=00,
                         "IFDATABASE=QAS, LANG=E, CLIENT=200, ASHOST=SAPECCQAS, SYSNR=00,
                         "IFDATABASE=PRD, LANG=E, CLIENT=300, ASHOST=SAPECCPRD, SYSNR=00];

// SWITCHTO command is used to Switch the Configuration File to the Centralized Configuration File

switchto = ["SAPWR:ZGXT.GUIXT.SJS"];                                          // Web Repository Deployment
// switchto = ["C:\\GuiXT\\Config\\GuiXT.SJS"];                              // Local Folder Deployment
// switchto = ["\\\\Network\\Subfolders\\Config\\GuiXTWR.SJS"];  // Network Deployment[/b]

const FLG_HIDE_CONSOLE = 0x00000000;
const FLG_RFCDIRECT_CONSOLE = 0x10008000;
const FLG_DISPLAY_CONSOLE = 0x00008000;


// TRACEFLAGS=FLG_DISPLAY_CONSOLE;
TRACEFLAGS=FLG_HIDE_CONSOLE;
===================================================================


Sample Centralized GuiXT.SJS file:
===================================================================
directory1 = "SAPWR:ZGXT";

license = [];
license.push({"license":"1-2012-36565-0-6874-1978B-563C9","data":{"company":"Synactive","systemid":["DEV","QAS"]}});
license.push({"license":"1-2012-36565-0-6874-1978B-563C9","data":{"company":"Synactive","systemid":["PRD"]}});

enablesystem = ["DEV","QAS","PRD"];

replication = "yes";                                      //File Caching Enabled

const FLG_RFCDIRECT_CONSOLE = 0x10008000;
const FLG_DISPLAY_CONSOLE = 0x00008000;
const FLG_HIDE_CONSOLE = 0x00000000;

TRACEFLAGS = FLG_HIDE_CONSOLE;
// TRACEFLAGS = FLG_REDIRECT_CONSOLE;
//TRACEFLAGS = FLG_DISPLAY_CONSOLE;
===================================================================