Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Sai Siddhartha on December 14, 2017, 08:41:25 AM

Title: Liquid UI - removefile command
Post by: Sai Siddhartha on December 14, 2017, 08:41:25 AM
Purpose:
The removefile command is used to delete files.
When a file is no longer needed, use the removefile command to delete the file. It is necessary to use the full path of the file.

Syntax:
removefile("filename.ext");

Example:
In below example, we will use removefile command to delete a sample file using WS function. The code would be as follows:

LiquidUI Code:
////////////////////////// SAPLSMTR_NAVIGATION.E0100.sjs ///////////////////////////

pushbutton([TOOLBAR],'Remove File','?',{'process':z_removefile});

function z_removefile(){
   removefile("file1.txt ");
}

The "file1.txt" is now deleted.