Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Rahul Gera on April 03, 2018, 11:44:54 AM

Title: Liquid UI system variables
Post by: Rahul Gera on April 03, 2018, 11:44:54 AM
Purpose:
To identify Liquid UI, SAPGui Version, and SAPgui PatchLevel Number.

The system variables "_version", "_sapgui_version" and "_sapgui_patch" can be used to find the version details of Liquid UI, SAPGui, and Patchlevel. Further to condition Liquid UI scripts.

For the below example, displayed in VA01 transaction.

Liquid UI Code:
---------------------------------------------------------------------------------
Script File Name: SAPLSMTR_NAVIGATION.E1000.sjs
---------------------------------------------------------------------------------


onUIEvents["Enter"]= {'fcode':"/0",'process':z_luiSysVar};

function z_luiSysVar()  {

      println("Liquid UI Version: "+_version);
      println("SAPGui Version: "+_sapgui_version);
      println("SAPGui Patch Level: "+_sapgui_patch);

  }