Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Rahul Gera on July 01, 2019, 12:29:18 AM

Title: Sample Liquid UI Table with different options
Post by: Rahul Gera on July 01, 2019, 12:29:18 AM
Purpose: Different options in Liquid UI Table columns

Syntax:
Numeric Input:                "numeric":true
Read-Only Column Field: "readonly":true
Uppercase:                      "uppercase":true

Searchhelp options

table([15,1], [25,150], {"name":"z_engr_bomtable", "title":"Create BOM", "rows":10});                                       // Liquid UI Table Generation
column("Item", {"table":"z_engr_bomtable", "name":"item_no", "position":1, "size":4, "numerical":true});         // Liquid UI Column accepting only Numeric Values
column("Document", {"table":"z_engr_bomtable", "name":"doc_no", "position":2, "size":25, "searchhelp":"CV01", "shselname1":"DOKAR", "shselvalue1":"DES",
                                    "shname1":"DOKAR","shdest1":"cell[z_engr_bomtable,Type,row]","uppercase":true});
column("Type", {"table":"z_engr_bomtable", "name":"doc_type", "position":3, "size":3, "readonly":true});         // Liquid UI Column Read-Only
column("Part", {"table":"z_engr_bomtable", "name":"doc_part", "position":4, "size":3, "searchhelp":"CV01", "fname0":"DOKTL", "uppercase":true});         // Liquid UI Column changing the input to UPPERCASE
column("Version", {"table":"z_engr_bomtable", "name":"doc_version", "position":5, "size":2, "searchhelp":"CV01", "fname0":"DOKVR", "uppercase":true});