Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: umang@guixt.com on June 23, 2020, 10:17:48 AM

Title: How to change title during screen automation
Post by: umang@guixt.com on June 23, 2020, 10:17:48 AM
The requirement is to display/change screen title during long function processing, when automating multiple screens

When the processing time exceeds few seconds, users becomes impatient, as well have the perception that the system is slow.
It makes sense in these scenarios, to indicate clearly that the system is carrying out substantial amount of task and therefore user needs to wait for the action to be completed.

With the use of title command, a suitable message can be displayed to the user during auto processing.
The title can be changed multiple times within each onscreen block and/or steps for a long running function.

Example

function testFunction() {

onscreen 'SAPLSMTR_NAVIGATION.0100'
   title("Reading Notification Data.. Please Wait..."
   enter('/niw23');

onscreen 'SAPLIQS0.0100'
   title("Navigation to Notification Screen.. Please Wait..."
   set('F[Notification]','10001291');
   enter();

}