Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sabir Mohammad

Pages: 1 2 [3] 4
31
Purpose:
    To allows the users to configure barcode types so that the desired value can be populated in to the inputfield after barcode scan.

Steps to Configure Barcode Camera Scanner:
Step 1: Navigate to the option "Configure Barcode scanner" under settings from the connections list.
Step 2: Tap on the "+" symbol.
Step 3: Select the barcode type, enter comments, enable and Save.
           Note: You can also use the option "Scan your barcode" if a particular type is not available in the dropdown list.
Step 4: Tap on the barcode type that was created.
Step 5: Tap on the "+" symbol.
Step 6: Enter Prefix, comments, enable - remove prefix, enter suffix, enable - remove suffix, select any option "Auto Enter" or "Auto Tab" based on your business requirement and save.
Step 7: Tap on back arrow.
Step 8: Tap on back arrow.
Step 9: Select the server to login.
Step 10: Navigate to the transaction and tap on the input field to scan.
Step 11: Camera will start and scan the value of the barcode to the desired input field.

Result: The barcode value that is populated to the input field will show the prefix and suffix eliminated and will also auto tab the position of the cursor as configured to the next control. (Refer Step.6 for configuration)

Original UPC-A Barcode Value: 022334545453 (Refer Step.11)
UPC-A Barcode Value fetched after scanning as seen below: 223345454

Note:
You can also disable or delete the configured barcode type using following steps:

Step 1: Navigate to the screen "Barcode Types", Tap and scroll to the left on the particular barcode type.
Step 2: Select option either Edit or Delete.

Step 2(a):
Disabling Configured Barcode type:
Result: The Barcode type's status will show as "Not Active".

Steps 2(b):
Delete Result: The Barcode type configuration will be deleted.












32
Purpose:
     Liquid UI Android/IOS allows user to avoid making manual entry of User Logon Credentials each time while logging into the server with the help of effective Auto Logon feature.

Step 1:
Navigate to "Edit Connection" for particular server on the server connections screen.
 
Step 2:
Enter the server credentials along with User name and password. Then click on button "OFF" for the option "Auto Logon".
 
Step 3:
The Auto Logon will get enabled by turning button to "ON". Hence click on "CONNECT TO MY SAP" to update the information.
 
Step 4:
The profile will be updated successfully. Now click on "CONNECT" for the particular server to Log IN.
 
Result:
You will be automatically redirected to SAP Easy Access Screen without the need of entering the username and password.
 


33

Purpose:
     Liquid UI IOS allows user to adjust the column width for better view ability and to be able to read the complete data within the cells with the help of slider.

Explaination using Grid control:

Following image shows the data within the Description column on a first view as truncated. See the highlighted cells.
 
The data within the above cells can be better viewed by adjusting the column width using a slider control as explained below.

Step 1:
Slowly position your finger on the respective column header and hold. A slider control will appear on the screen.
 

Step 2:
Now position your finger on the bigger arrow of the slider as highlighted and move it towards right to increase the width of the column.
 

Result:
You will see that the "Description" column width has increased and the data within the cells which earlier looked truncated is now better viewable.
 
Similarly you can use the slider control and make left movement to decrease the width of the column.



34

Purpose:
     Signature is a new feature introduced on Liquid UI IOS to help the user further validate the report by uploading their signature in key business scenarios as proof of authentication.

Example:
1. Navigate to any transaction which has SFO like IW24.

2. To the top right corner on the screen, one will see SFO - symbolically a paper clip, Hence Tap on it to select the option "Create Attachment".
 
3. select the option "signature" from the pop-up list.
 
4. Draw the signature within the empty area and click on "Done".

5. A notification will be successfully generated.
 

35
Purpose:
      Liquid UI Android provides a useful and efficient feature to add the Server connection on to the connection list of Liquid UI Android, with the help of Scanning QR Code generated by the 'Connection Transmitter' executable, which is provided with Liquid UI SDK. This feature will replace the need of adding the server connection manually on to the connection list.

Steps:
1. Run the file 'Connection Transmitter.exe' as an administrator on your windows machine. The following window will be generated with a list of connections fetched from your SAP Connection list. Now click on the desired connection.
 
2. A QR Code will pop-up on your machine.
 
3. Now open Liquid UI Android and navigate to the option 'Scan to Add Connection' under settings.

36
WS aka Web Scripts (Attended RPA for SAP) / Using toMultiByte Command
« on: August 17, 2017, 11:09:28 AM »
Purpose:
The 'toMultiByte' command is used to encode text returned by a call command into multibyte characters so that a non-Unicode R/3 system can process the data.

Syntax:
var z_DesiredText = "original_string";
var z_ToSendToRFCCall = "IPC"+toMultiByte(z_DesiredText);

Note: The 'z_DesiredText' value contains the characters that will be changed to multibyte. The 'z_ToSendToRFCCall' variable contains the value after it has been changed into multibyte characters.

Options:
The toMultiByte() command does not take any options.

Example:
The following example demonstrates the command usage:
Open the script file for the SAP Easy Access screen and enter the following code.

for(a=firstChild; a!=null; a=a.nextSibling)
a.del( );
var z_abc = "*お化け屋敷*";

To correct this problem, you will use the toMultiByte() command in your script. The non-unicode characters in the string would be converted to multibyte character representation, for a non-unicode R/3 server to interpret the data correctly. The revised code is:

for(a=firstChild; a!=null; a=a.nextSibling)
a.del( );
var z_abc = "*お化け屋敷*";
var z_ToSendToRFCCall = "IPC"+toMultiByte(z_abc);

37
Purpose:
     Liquid UI Android allows the user to change the view of the Table Layout on a SAP screen for better viewability.

Steps:
1. Start Liquid UI Android and on the connection list screen, single tap the settings icon to the left top corner - symbolically three horizontal lines.
2. Select the option "App Settings".
3. Scroll down the Insider to select "Readable Layout" from the scroll down option of "Table Layout".
4. Following IW21 transaction screen comparison between Readable Layout and SAP Layout shows the difference in user viewability, as using the Readable Layout the user can view the full column names and the table cell width is more when compared to SAP Layout.

38
Purpose:
     Liquid UI Android provides the user the choice to set the Text Color of the screen area.

Steps:
1. Start Liquid UI Android and on the connection list screen, single tap the settings icon to the left top corner - symbolically three horizontal lines.
2. Select the option "App Settings".
3. Scroll down the Insider to select the option "Text Color".
4. You will get a popup on which there are two areas to select the color from. i.e., a square area with a circular bar for selection and a rectangular area with a rectangular bar.
5. Move the circular bar to any position on the square area so that the button "DONE" changes the text color on it, indicating selection of color.
6. However, to utilize further available colors from the rectangular area, move the rectangular bar to any position based on your choice of color and click "DONE".
7. Navigate to the connection list to login to the server to see the changes take effect.
8. To take-off the Text Color back to its original, follow steps 1-3 and click on "DONE".

39
Purpose:
     Liquid UI Android provides the user to set the background image of the screens by selecting the picture from the device or by clicking a picture using device's built-in camera.

Steps:
1. Start Liquid UI Android and on the connection list screen, single tap the settings icon to the left top corner - symbolically three horizontal lines.
2. Select the option "App Settings".
3. Scroll down the Insider to select the option "Background Image".
4. Now choose either "Select" or "Snap".
4(a). Choosing "select" allows you to set the background image from your device.
4(b). Choosing "Snap" starts the built-in camera on your device. So that you can take a picture and set that picture as the background image.
4(C). You can use the option "Remove" to take-off  the background image to its Original.

40
Purpose:
     As in SAPGUI Liquid UI Android also provides the user to change the display of system messages as per the convenience of the user.

Steps:
1. Start Liquid UI Android and on the connection list screen, single tap the settings icon to the left top corner - symbolically three horizontal lines.
2. Select the option "App Settings".
3. Scroll down the Insider to select the option "System Message Style".
4. Now choose any of the options based on the screen size of your device or as per the convenience.
5. Navigate to the transaction to see the changes taking effect.

41
Purpose:
As in SAPGUI, LiquidUI Android allows the user to open and manage multiple sessions effectively.

Usage:
1. Navigate to the connection list screen and click on the button - "connect", for a particular server you wish to login.
2. Once Logged IN, select the settings menu   to the top left corner.
3. You will see the number of sessions that are currently opened.
 
Click on "Close Current" or "Close Session" to close the active session highlighted with radio button and navigate to "Server Connections" screen or else click "Home Screen" to directly navigate to "Server Connections" screen to see the total number of sessions active.

4. Click on "Open" to start managing multiple sessions.
5. Selecting "Existing Connections" shows you details about the sessions as shown below that are active, allowing you to take further actions. Whereas selecting "New connection" opens a new session for that particular server.
 


42

Purpose:
As in SAPGUI, LiquidUI Android also allows a user to create a variant with set of parameters which later can be used to run a program with that variant as required.

Usage:
1. Navigate to transaction IW37.
2. Select the menu bar, symbolically - brush icon   to the top right corner to select the option "Goto".
3. Now click on "Variants".
4. Now select "Save as Variant…"
5. On the next screen you can choose the parameters, such as name, description and other parameters and then click on SAVE to save the variant.
 
 


43
Desktop Product (SAP GUI, Excel and PDF) / Using SynSerialManager
« on: July 06, 2017, 11:24:52 AM »
Purpose:
To effectively manage Liquid UI product Licenses and to fetch the Host ID of Physical Server machine in case of applying for a new license.

License Verification:
   Step 01: Navigate to the  Liquid UI product folder location to find "SynSerialManager.exe".
   Step 02: Now right click and "Run as administrator".
   Step 03: Synactive License Manager will pop-up, containing the License keys.

      1.1 Request for New License:
            Step 01: Click on "Request New" which will open the browser with an online form to be filled up with the necessary details like the HostID.
            Step 02: Click on "Copy HostID" to populate HostID of your machine.
            Step 03: Send the HostID in the online form starting with "S".

      1.2 Installation of License:
            Step 01: Now click on "Import License File" to add the license.
            Step 02: Navigate to the folder and select the appropriate license file with extension .sy9 and click on "Open".
            Step 03: You will get the following pop-up on success. Click on "OK".
            Step 04: Click "Apply" and the license installation is complete.

      1.3 Validation of License:
            Step 01: The license key will be shown as added. Now click on "Validate" to check the valid no.of days for license expiry.

      1.4 Removal of License:
            Step 01: Select the license key and click on "Remove".

44
Pre-requisite:
Enable the location service from the Notification area on the device.

Purpose:
      Providing the coordinates of geographical location of the device where the notification or document or order was generated by the end-user for later tracking.

Usage:
1. Navigate to any transaction.
2. Now single tap and hold on the desired input field.
3. A strip of options will pop-up on the screen. Select GPS.
4. The geographical coordinates of the device will be fetched to the input field.

45
Purpose:
        As in SAPgui, Liquid UI for Android and iOS also provides the user the ability to create an attachment, view the attachment list and store business document using the option Services for Object (SFO).
 
Usage Scenario(s):
        End-user wants to report malfunction with an equipment, by uploading a file, picture or a video using the device's built-in camera. so that the technician can be notified with relevant data.

Example:
1. Navigate to any transaction which has SFO like IW24.
2. To the top right corner on the Liquid UI screen, a paperclip icon (SFO) is visible.
3. Tap on it to use any of the options as per the requirement.

Note: Recording a video and uploading the document from icloud account is feature  available only on Liquid UI iOS.
.
.
.
.
see the attachment for details

Pages: 1 2 [3] 4