Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
31
Purpose: Below Article would help in changing the F4 help display options.

Following are the Steps that needs to be followed:

Step-1: Connect to the SAP Server from the Liquid UI Client.

Step-2: On the SAP Easy Access Screen at the top right corner of the screen, Tap on the Settings Icon for iOS and More Option for Android.

Step-3: Under the System Menu Tap on Help.

Step-4: Tap on Settings...

Step-5: On the Screen Personal Settings for User, Tap on the F4 Help Tab.

Step-6: Select the Radio button Dialog(Modal) / System defaults and Tap on the Continue tick mark button.

Step-7: It will display the success message.


Refer to the Attachment for Clarity....
32
Purpose: To resolve the issue of SAP web repository not rendering Liquid UI Scripts and also guide in releasing MIME Object

Pre-requisites:
  • Valid RFC Username and Password.
  • RFC Proper Authorization to Execute requested RFC function.
  • Valid RFC Connect Statement.

To Know more about RFC Connect Statement, refer the below Article:
https://www.guixt.com/forum/index.php/topic,427.msg431.html#msg431

Following needs to be verified in-order to resolve the issue:

1. RFC Username and Password,

2. Valid RFC Connect Statement in the guixt.sjs file.

3. Directory path should be correctly specified in the guixt.sjs file.

To Know more about How to Specify the Directory Path for SAP Web Repository, refer the below Article
https://www.guixt.com/forum/index.php/topic,435.0.html

Example:
directory1="SAPWR:Z.LIQUIDUI";

4. Liquid UI Scripts should be Properly Uploaded into the SAP Web Repository.

If the Above Steps doesn't resolved the issue then release the MIME Object by following the below steps:

Step-1: Navigate to 'SMW0' transaction and select second option.

Step-2: Click on 'Internet Release' Menu Item from top of the screen and select 'Function Module'.

Step-3: Put "WWW_GET_MIME_OBJECT" within function module and click on Release TOOLBAR Pushbutton.

-If it has already been released, it will display a message "the function module WWW_GET_MIMIE_OBJECT has already been released for the Internet", or else it will make new release.

Step-4: Restart and Login again to the SAP Server.


Refer to the Attachment for further clarity.....
33
Purpose: To display the Text/Name value associated to a particular Entry/Record of SAP.

  • Generally, the Description of the value entered is not displayed in Liquid UI.
  • Below Article would help in displaying the description of the value entered using Liquid UI WS.

Pre-requisites:
Liquid UI WS
Liquid UI Designer

Example:

Step-1: Open the Script file "SAPLSTMTR_NAVIGATION.E0100.sjs" or Create it if it is not present in the WS Directory as configured in the "guixt.sjs" file.

Step-2:
Add the below Code and save it.

//Liquid UI Code:

//////////////////////////////"SAPLSMTR_NAVIGATION.E0100.sjs"//////////////////////////////
// User Interface / Design Screen
clearscreen();
box([3,0], [8,98], "Organizational Data");
inputfield( [1,2], "Order Type", [1,20],{ "name":"z_ordertype", "size":5});
text([1,27], "&V[z_ordertype]",{ "size":20});
inputfield( [4,2], "Sold-To Party", [4,20],{ "name":"z_soldtoparty", "size":8});
text([4,30], "&V[z_soldtopartyvalue]",{ "size":22});
inputfield( [5,2], "Sales Organization", [5,20],{ "name":"z_salesorganization", "size":8});
text([5,30], "&V[z_salesorg]",{ "size":20});
inputfield( [6,2], "Distribution Channel", [6,20],{ "name":"z_distrchnl", "size":8});
text([6,30], "&V[z_distributionchan]",{ "size":22});
inputfield( [7,2], "Division", [7,20],{ "name":"z_div", "size":8});
text([7,30], "&V[z_division]",{ "size":20});

//Function to Read the Text/Name Value of the Fields
function getvalue(){
   onscreen 'SAPLSMTR_NAVIGATION.0100'
   enter("/nva01");
   onscreen 'SAPMV45A.0101'
   set("F[Order Type]","&V[z_ordertype]");
   set("F[Sales Organization]","&V[z_salesorganization]");
   set("F[Distribution Channel]","&V[z_distrchnl]");
   set("F[Division]","&V[z_div]");
   enter();
        onerror     // Error Handling
        enter("/n");
        message(_message);
        goto End;
   onscreen 'SAPMV45A.4001'
   set("F[Sold-To Party]","&V[z_soldtoparty]");
   enter();
   onscreen 'SAPMV45A.4001'
   enter("/2");
   set("V[z_soldtopartyvalue]","&F[KUAGV-TXTPA]");
   enter("/3");
   onscreen 'SAPMV45A.4001'
   enter("/3");
   onscreen 'SAPLSPO1.0100'
   enter("=NO");
   onscreen 'SAPMV45A.0101'
   set("V[z_salesorg]","&F[TVKOT-VTEXT]");
   set("V[z_distributionchan]","&F[TVTWT-VTEXT]");
   set("V[z_division]","&F[TSPAT-VTEXT]");
   enter("/3");
   End:;
}
onUIEvents["Enter"]={"process":getvalue};

Note: The Above "getvalue" Function is recorded using Liquid UI Designer.

Step-3:
Login to SAPGUI and Navigate to "SAP EASY ACCESS SCREEN", Enter the Order Type, Sales Organization, Distribution Channel, Division and Hit Enter or Click on the Enter Button.

Step-4: It will display the description of the value entered in Liquid UI Invisible Text Elements.


Refer to the Attachment for clarity....

34
Purpose: Download and installation of Liquid UI Server on a Physical or a Virtual Machine in a cloud environment with providers like Azure, AWS, Google Cloud, or Third Party Data Centers

Pre-requisite:
1. Windows OS

Supported OS: Windows Server 2003 and Above


Highly Recommended: Installation of latest or available SAPGUI version on the same machine

Software download links, for the latest version of Liquid UI Server
64bit Windows OS  -->  http://updates.guixt.com/secured/LiquidUIServerSetup_64.exe

Note: Installation of the above Setup file(s), needs to be performed by an ADMIN on the machine, and as an Administrator (Right Click on the .exe, and choose "Run as administrator".

Default Liquid UI Server installation location, on a Windows Machine
64 Bit O.S --> 64 Bit Liquid UI Server Software --> C:\Program Files\Liquid UI\Liquid UI Server

Below step is needed only, if Liquid UI Server being Migrating Liquid UI Server to New Hardware or New Virtual Machine in the cloud
Please copy and paste, the below from the Backup
   1. sapproxy.ini
   2. guixt.sjs

License is required to Execute Liquid UI Server software.

For requesting Liquid UI Server license, refer to below article.
http://www.liquid-ui.com/forum/index.php?topic=228

For Installation of Liquid UI Server License, refer to below article
http://www.guixt.com/forum/index.php/topic,400.0.html

For Configuration of Liquid UI Server, refere to below articles
SAP Application Server: http://www.guixt.com/forum/index.php/topic,369.msg373.html#msg373
SAP Message Server: http://www.guixt.com/forum/index.php/topic,370.msg374.html#msg374
35
Purpose: To Display the Selected SAPGUI Table Rows Details Associated to Particular Columns in a Pop-up Window Liquid UI WS.

-Because accessing the Row Details of the Table which are at the Extreme end is only possible through scrolling which is generally a tedious process.

-We can also display multiple table row details in a Pop-up Window.

Example:
Please follow the Steps below.

Step-1 : Create a script file "SAPMV45A.E4001.sjs" with the following code and save it in your WS scripts directory as configured in "guixt.sjs"  file.

Liquid UI Code

///////////////////////////////////////////////SAPMV45A.E4001.SJS///////////////////////////////////////////////

//Design Script
pushbutton([TOOLBAR], "@0P@Display Row Data..",{"process":DisplayRowData});

//function to fetch the Selected Table Row and store it in the Respective Array.
function DisplayRowData(){
   z_matarray=[];
   z_pricingdatearray=[];
   z_billingdatearray=[];
   z_itemarray=[];
   z_accassigngrparray=[];
   z_quantity=[];
   enter("/o");
   gettableattribute("T[All items]", {"firstvisiblerow":"FVisRow", "lastvisiblerow":"LVisRow", "lastrow":"LastRow","selectedrows":"SelRows"});
   for(i=0;i<LastRow;i++){
   ROW_NUMBER = i;
      if(SelRows[ROW_NUMBER]=="X"){
         // adding 1 as SelRows is array which has index begin from 0
         selected_row_number = ROW_NUMBER+1;
         set("V[z_item]","&cell[All items,Item,"+(selected_row_number)+"]");
         z_itemarray.push(z_item);
         set("V[z_material]","&cell[All items,Material,"+(selected_row_number)+"]");
         z_matarray.push(z_material);
         set("V[z_pricingdate]","&cell[All items,Pricing date,"+(selected_row_number)+"]");
         z_pricingdatearray.push(z_pricingdate);           
         set("V[z_billingdate]","&cell[All items,Billing Date,"+(selected_row_number)+"]");
         z_billingdatearray.push(z_billingdate);
         set("V[z_accassigngroup]","&cell[All items,VBAP-KTGRM,"+(selected_row_number)+"]");
         z_accassigngrparray.push(z_accassigngroup);
       set("V[z_compquantity]","&cell[All items,Component quantity,"+(selected_row_number)+"]");
         z_quantity.push(z_compquantity);
      }       
    }
 }

Step-2 : Create another script file "RSM_ALV_NEW_E2000.sjs" with the following code and save it in your WS scripts directory which is configured in "guixt.sjs" file.

///////////////////////////////////////////////RSM_ALV_NEW_E2000.SJS///////////////////////////////////////////////

//Design Screen
clearscreen();
title('Displaying Selected Row Details', {"size":[1,10]});
del('P[Generate]');
del('P[End Session]');
del('P[Delete Session]');
del('P[Continue]');
text('P[Cancel]',"@2O@");
inputfield([0,0],{ "size":5, "intensified":true, "nolabel":true, "default":"Item", "readonly":true});
inputfield([0,6],{ "size":11, "intensified":true, "nolabel":true, "default":"Material", "readonly":true});
inputfield([0,18],{ "size":11, "intensified":true, "nolabel":true, "default":"PricingDate", "readonly":true});
inputfield([0,30],{ "size":11, "intensified":true, "nolabel":true, "default":"BillDate", "readonly":true});
inputfield([0,42],{ "size":11, "intensified":true, "nolabel":true, "default":"AccountAssignGrp", "readonly":true});
inputfield([0,54],{ "size":5, "intensified":true, "nolabel":true, "default":"Quantity", "readonly":true});

//Creating the Inputfields
for(j=0;j<z_matarray.length;j++){
   inputfield([j+1,0],{"size":5,"name":"z_item_&V[j]","nolabel":true,"readonly":true});
   inputfield([j+1,6],{"size":11,"name":"z_matarray_&V[j]","nolabel":true,"readonly":true});
   inputfield([j+1,18],{"size":11,"name":"z_pricingdate_&V[j]","nolabel":true,"readonly":true});
   inputfield([j+1,30],{"size":11,"name":"z_billingdate_&V[j]","nolabel":true,"readonly":true});
   inputfield([j+1,42],{"size":11,"name":"z_accassigngrp_&V[j]","nolabel":true,"readonly":true});
   inputfield([j+1,54],{"size":5,"name":"z_quantity_&V[j]","nolabel":true,"readonly":true});
}

//Displaying the array values in inputfields
for(j=0;j<z_matarray.length;j++){
   set("V[z_matarray_&V[j]]",z_matarray[j]);
   set("V[z_billingdate_&V[j]]",z_pricingdatearray[j]);
   set("V[z_pricingdate_&V[j]]",z_billingdatearray[j]);
   set("V[z_item_&V[j]]",z_itemarray[j]);
   set("V[z_accassigngrp_&V[j]]",z_accassigngrparray[j]);
   set("V[z_quantity_&V[j]]",z_quantity[j]);
}

Step-3 : Goto the Transaction VA02, Enter the Order Number and Click on the Enter Button.

Step-4 :Select the Rows of the "All items" Table and Click on the "DisplayRowData" TOOLBAR Pushbutton.

Step-5 : It will display the Selected Row Details Row Details Associated to Particular Columns in a Pop-up Window.


Refer to the Attachment for further Reference...
36
This article is applicable to
Liquid UI for Android Version : 4.0.13.0 and BELOW

Explanation of SY9 Enterprise Production Edition License

Synactive's perpetual license allows the Licensee to use the software for as long as the Licensee/end user complies with all terms of the license agreement. The end user is required to pay for maintenance annually. As long as the user pays maintenance, they have a right to upgrade to any version of the software that is released during the maintenance period.

Licensee must pay Synactive's then annual fee in order to continue Product Technical Support and Update Rights for the Software, its versions and its documentation.
Not paying maintenance will result in loss of rights to any subsequent upgrade versions, (including online store downloads) and loss of any Synactive support. If there is a maintenance lapse, returning to maintenance in any given year will require payment for that year and a negotiated amount for each of the years of the maintenance lapse including penalties.

Upon paying maintenance, a new SY9 license will be generated with the upgrade validity/maintenance to date extended based on the number of years of paid maintenance.

Terminology of SY9 License Document

For the purpose of SY9 Perpetual production Licenses, Valid Till/Expires in date specified means Upgrade Validity/Maintenance To date, and is used interchangeably in any type of communication.

Please refer to attached document for additional details
37
Mobile Products (Android, iOS and CE) / Dark Mode for Liquid UI Android
« Last post by Saisree Paluri on January 22, 2021, 02:53:24 AM »
Purpose: To make it easier for the user to use the application in a low-light environment.
Pre-requisites: Liquid UI Android version 4.0.12.2.
Steps:
1. Launch Liquid UI Android App and from the Options Tap on (☰) Menu, Tap on App Settings.
2. For Dark Mode Option, tap on "Always on".
3. Now the Complete Application will change into Dark Mode.

Automatic Option:
1. By enabling the Liquid UI App Dark Mode setting to Automatic. the Liquid UI App takes the Dark mode settings of the Android device and will apply those settings accordingly to itself. This will help the user not to change the Dark mode setting frequently with in the App if the user prefers to have the Dark Mode settings within the device applied to the Liquid UI App automatically.
2. This automatic option is available for Android devices OS version 10 and higher.
3. Launch Liquid UI Android App and from the Options Tap on (☰) Menu, Tap on App Settings.
4. For Dark Mode Option, tap on "Automatic".
5. Use the system setting (Settings -> Display -> Dark mode) to enable Dark mode.

Result: Now the Application will change into dark mode as we choose Automatic.

Note: The text color within the Liquid UI app is set to default as black, then after changing the Dark Mode, the text color will change to white. Similarly, if it is on Red without Dark Mode, after changing to Dark Mode, the text color will become Blue.

To check further how to change the text color within the Liquid UI App, please follow the below article.
https://www.guixt.com/forum/index.php/topic,244.msg248.html#msg248
38
Purpose: To help the user easily make entries into the table/grid controls with the help of UI assist pop up.
Pre-requisites:
• Liquid UI Android version 4.0.11.0,
• Turn ON "UI Assist" on App settings.
Steps:
1.   Launch Liquid UI Android.
2.   Connect to your SAP Server.
3.   Navigate to any transaction. For example, VA01 transaction.
4.   In VA01 Transaction, On Screen "Create Standard Order: Overview", in All items GRID. Long Tap on the first row.
5.   You will get an UI Assist popup which will show the details of all the columns in the grid. Enter the data of columns that you need and tap on "Done".
6.   By taping on Done, the entered data will be updated in the Grid.
7.   If you Tap on Next, you will able to enter the details of the Next available row.
8.   If you Tap on Previous, you will able to navigate back to the previous row where to make the entries.
9.   Enter the data of columns and tap on "Enter".
10. By taping on Enter, the grid data will be executed.


39
Purpose:  Copying the Material Number, Sales Order Number etc., after the successful completion of transaction with the help of Performance Assistant popup.

Steps: 
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. Navigate to any transaction. For example, VA01 transaction.
4. After the transaction is successfully completed, Long Tap on Status Message.
5. You will get a performance Assistant Popup which will show the Order Number. Long Tap on the text to Copy the Order Number. Tap on Copy from the context menu as shown.

Result: You can now Paste the Order number in your Excel Spreadsheet on your mobile device.

Refer to the Attachment for Clarity....


40
Purpose:
To Open the Excel File with a Click of Pushbutton.
-It is helpful in opening the Desired Excel file from within the SAP Screen.

Pre-requisites:
Liquid UI WS
Microsoft Excel

Note:
"wsoffice.dll" file must be present in the Script Directory and it should be Loaded in "ESESSION.SJS" File

Eg:
////ESESSION.sjs////
load("wsoffice");

Example:
Please follow the below Steps:

Step-1: Open the Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.

//Add the Below LIQUID UI Code to the file

/////////////////////////////SAPLSMTR_NAVIGATION.E0100.SJS/////////////////////////////

// Function to Select the Excel File
function SelectExcelfile(param){                                       
    if(szPrompt==void 0) szPrompt = 'Select the Excel File';
    var dialog = new ActiveXObject('MsComDlg.CommonDialog'); 
    dialog.Filter='Excel Files(*.xlsx*)|*.xlsx*'; 
    dialog.MaxFileSize=32767; 
    dialog.DialogTitle=szPrompt;
    dialog.Flags=0x200|0x80000|0x800|0x4|0x200000;
    dialog.ShowOpen(); 
    var file = dialog.FileName;
    dialog = void 0;
    if(file!=""){
        openExcelfile(file);
    }
    else{
       message("File Not Selected!",{"StatusLine":true,"title":"Information","type":"W"});
    }

}

// Function to Open the Excel File
function openExcelfile(filename){
g_ExcelApp = new ActiveXObject('Excel.Application');
g_ExcelBook=g_ExcelApp.Workbooks.Open(filename);
g_ExcelApp.Visible=true;
g_ExcelApp.ScreenUpdating=true;
message("S: "+filename+" Excel File is Opened Successfully");
}

// Screen Script
pushbutton([TOOLBAR], "@48@Open Excel File",{ "process":SelectExcelfile});


Step-2: Save the File and Refresh the SAP Screen.

Step-3: Click on the "Open Excel file" TOOLBAR Pushbutton.

Step-4: It will bring up the Pop-up Window, Select the Excel file that need's to be open.

Step-5: It will display a Success Message and will open the Selected Excel File.


Refer to the Attachment for Further Reference......
Pages: 1 2 3 [4] 5 6 ... 10