Recent Posts

Pages: 1 ... 3 4 [5] 6 7 ... 10
41
Purpose: To update license key for Liquid UI Mobile Software

Steps to update the License on Handheld Device for Liquid UI Mobile Software:
Step 1: Connect the Handheld to computer (PC), so that the "SynMobile" Folder can be accessed.
Step 2: Copy and Paste the License file with extension ".Sy3" from "SynMobile" Folder to PC.
Step 3: Open the new license file provided by Synactive.
Step 4: Copy the [General] section until the line LLicense  from the new license file and update the lines in old license file.
            - Updating the license information in old license file will keep the previous SAP logon settings on the device.
Step 5: Save the updated License file and overwrite the file in "SynMobile" Folder on the handheld device.
Step 6: Start the Liquid UI Mobile application.
42
Purpose:
To enable ABAP text-based editor to display the source code of a function module when using Liquid UI for iOS.

Please refer to the attachment for step-by-step instructions and screenshots!
43
Purpose:  To install Liquid UI Android license through .SY9 License file, when you don't have access for the network.

Pre-requisites:  Liquid UI Android version 4.0.4.7 or later.

Request for New License:
1. Launch Liquid UI Client App, Tap on About.
2. Tap on the Synactive ID (SB4308485) to copy the ID to your clipboard as shown.
3. Send us an email to support@guixt.com, with the Synactive ID copied from the device as shown above or contact your AE.

Installation of License using a QR code:
1. After receiving the sy9 license in QR code format upon requesting Liquid UI through email.
2. Launch Liquid UI Client App, Tap on "Request License".
3. Tap on "Apply License" and tap "SCAN LICENSE", the device's camera will open to scan the QR code.
4. After a successful scan, the license will be applied automatically to your Liquid UI Android.


Installation of License using a Scan Gun:
1. Once you tap on "Apply License" and it will navigate to the next screen to add the license key and tap "SCAN LICENSE", point the scanner to scan the QR code.
2. After a successful scan, the license will be applied automatically to your Liquid UI device.


Installation of License using a License Key:
1. Once you tap on "Apply License" and it will navigate to the next screen to add the license key. In the input field, enter the sy9 license key and tap the Submit button.
2. The license will be applied automatically to your Liquid UI Android.

44
Purpose: Setting Set Start Transaction on Liquid UI Client.

To Set Start Transaction on "Liquid UI iOS Client"

Please follow the Steps Below:

Step-1: Launch LIQUIDUI App in the iOS Device.

Step-2: Connect to the SAP Server Connection.

Step-3: On the SAP Easy Access Screen, Tab on the Settings TOOLBAR Pushbutton.

Step-4: System Menu WINDOW will Pop-up Tap on the Extras Option.

Step-5: Tap on the Set Start Transaction option.

Step-5: Set Start Transaction WINDOW will Pop-up, Specify the Transaction in Transaction Code field and Click on the Continue button as Shown.

Step-6: Login again to the SAP Server Connection, it will redirected to the Specified Transaction.


To Set Start Transaction on "Liquid UI Android Client"

Please follow the Steps Below:

Step-1: Launch LIQUIDUI App in the Android Device.

Step-2: Connect to the SAP Server.

Step-3: On the SAP Easy Access Screen Top right Corner, Tap on the More Option Pushbutton.

Step-4: Tap on the Extras Option.

Step-5: Tap on the Set Start Transaction Option.

Step-6: Set Start Transaction WINDOW will Pop-up, Specify the Transaction in Transaction Code field and Click on the Continue button.

Step-7: Login again to the SAP Server, it will redirected to the Specified Transaction.


Refer to the Attachment for Clarity.....
45
Purpose : To Add Other Objects such as Web Address or file on the SAP Easy Access Screen inside the Favourites List Node.

To Add Web Address on Liquid UI iOS Client

Please follow the Steps Below:

Step-1: Launch the LIQUIDUI App in the iOS Device.

Step-2: Connect to the SAP Server.

Step-3: On the SAP Easy Access Screen, Click on the Settings TOOLBAR Pushbutton.

Step-4: System Menu WINDOW will Pop-up, Scroll down and Select the Add Other Objects Options.

Step-5: "Add additonal objects 32 Entries" Window will Pop-up, Select the web address or file and Click on the Continue button.

Step-6: "Add a Web address or file path" WINDOW will Pop-up, Specify the "Text"  as "Company's Website" and the "Web Address or File as "https://www.guixt.com"[/color] fields and Click on the Continue button as Shown.


Step-7: It will show the Success Message and the Node is added to the favourite list.


To Add Web Address on Liquid UI Android Client

Please follow the Steps Below:

Step-1: Launch the LIQUIDUI App in the Android Device.

Step-2: Connect to the SAP Server.

Step-3: On the SAP Easy Access Screen Top right Corner, Tap on the More Option Pushbutton.

Step-4: Tap on the Favorites from the List of options.

Step-5: Tap on Add other objects.

Step-5: "Add additonal objects 32 Entries" Window will Pop-up, Select the web address or file and Click on the Continue button.

Step-6: "Add a Web address or file path" WINDOW will Pop-up, Specify the "Text"  as "Company's Website" and the "Web Address or File as "https://www.guixt.com"[/color] fields and Click on the Continue button as Shown.

Step-7: It will show the Success Message and the Node is added to the favourite list.

Refer to the Attachment for further Reference.....
46
Purpose: To find the List of users connected to the Liquid UI Server.

Please follow the below Steps:
1. Login to the relevant SAP system.
2. Navigate to SM04 transaction.
3. Place a filter with IP Address of the Liquid UI Server machine.

Refer to the Attachment for further Reference.....
47
Purpose:
For several functions, Liquid UI uses an RFC connection to the SAP System (Remote Function Call).
In order to logon to the system, the RFC needs a user name and password.

Liquid UI uses the logon values stored in Liquid UI profile.
As a default, the Liquid UI profile contains the user "SAPCPIC".
Since this user is often locked in productive systems, we suggest you create a special Liquid UI RFC user with appropriate rights.

For testing purposes, you can also fill in your own user name and password in Liquid UI profile.

Please refer to the attachment for step-by-step instructions on creating a role with required RFC authorizations!
48
Purpose:
For the searchhelp on Liquid UI fields to work, you need to install the ABAP program (ZGUIXTF4) in your SAP ERP system and also assign a transaction code ZXF4 to this program.

NOTE:
You can download the ABAP program ZGUIXTF4 from the below link:
http://updates.guixt.com/downloads/zguixtf4.zip


Please refer to the attachment for steps to install!
49
WS aka Web Scripts (Attended RPA for SAP) / Arrow Functions in Liquid UI WS
« Last post by Ashfaq Ahmed on August 28, 2020, 09:45:31 AM »
Purpose : Arrow functions allow us to write simple and shorter function Syntax.

***ES6's Arrow functions are now supported in Liquid UI WS

Pre-requisites :
Liquid UI Desktop with version 1.2.365

Syntax:
Test= () => {
return "Hello World";
}
pushbutton ([1,1],"Click Me!", {"process": Test});


Note:
If the function consists of a single line statement and it is returning a value, then skip the return keyword, as Arrow function returns value by default
Test= () => {
"Hello World";
}
pushbutton ([1,1],"Click Me!", {"process": Test});


If the Function has only one parameters, then skip the brackets ().

Example:
Below Example Illustrate the use of Arrow Function, please follow the below steps.

Step-1: Create a script file "SAPLSMTR_NAVIGATION.E0100.sjs" with the following code and save it in your WS scripts directory as configured in guixt.sjs" file.

Liquid UI Code:
// Screen Script
del("X[IMAGE_CONTAINER]");
inputfield ([1,0],{ "name":"z_username", "size":21, "nolabel":true});
z_date = Date();

pushbutton ([1,23], "@0V@Submit   ",{ "process":Test, "using":{"user":z_username,"day":z_date}});


// Arrow Function
Test=param=>{
   "S: "+"Welcome"+param.user;
   "S: "+"Today's date is "+param.day;
}

Step-2: Login to your SAP Server, On the SAP Easy Access Screen Enter some text in the inputfield and Click on "Submit" Pushbutton it will display a Success Message on the Status Bar.


this Keyword in Arrow Function:

this keyword is different in Arrow functions as compared to regular functions.

this keyword represents the object that define the arrow function.

There is no binding of this with arrow function.

Example

Step -1: Create a script file "SAPLSMTR_NAVIGATION.E0100.sjs with the following code and save it in your WS scripts directory as configured in "guixt.sjs" file.

Liquid UI Code:
// Screen Script
del("X[IMAGE_CONTAINER]");

// New implementation of "this" keyword
Test= ()=>this;
pushbutton ([1,1],"Test Arrow function this keyword ",{"process": Test});

// regular function with "this" keyword
function thiskeyword(){
   return(this);
}
pushbutton ([3,1],"Test regular function this keyword",{"process":thiskeyword});


Step-2: Login to your SAP Server, On the SAP Easy Access Screen Click on "Test regular function this keyword" Pushbutton it will display "[Object Screen]" on the status bar.

Step-3: Login to your SAP Server, On the SAP Easy Access Screen Click on "Test Arrow function this keyword" Pushbutton it will display "[Object global]" on the status bar.


Refer to the Attachment for further Reference.....
50
Purpose: To Encrypt Liquid UI RFC Password.

Please follow the steps below:

Step-1: Enter /wsmessage(encrypt("YOUR PASSWORD"),1) on SAP Screen (in the tcode box) and hit enter.
 
Step-2: "Message" Window will Pop-up, Copy the Encrypted Password from the Message Field.

Step-3: Put the Copied Encrypted Password into the guixt.sjs file as shown below.
               
                rfcuser = "GXTRFC";
                rfcencryptedpassword = "encrypted password";


Refer to the Attachment for Clarity.....
Pages: 1 ... 3 4 [5] 6 7 ... 10