Recent Posts

Pages: 1 ... 4 5 [6] 7 8 ... 10
51
Purpose:
To Upgrade the Liquid UI Server on Sandbox Environment.

Pre-requisites:
Liquid UI Server with valid License.

Please follow the below steps:
Step-1. Download the latest Liquid UI Server version files from the Below Link.
             LiquidUI Server Files --> 32 bit
             LiquidUI Server Files --> 64 bit

Step-2. Copy the files on to Liquid UI Server sandbox machine.

Step-3. Stop "Synactive R/3 proxy" service.

Step-4. BACKUP just two files: sapproxy.exe, webscript.dll (from current Liquid UI Server installed folder eg: C:\Program Files\Liquid UI\LUI Server).

Step-5. Now place the downloaded files (sapproxy.exe, and webscript.dll) in Liquid UI Server folder.

Step-6. Restart "Synactive R/3 proxy" service.

Step-7. Verify the new Liquid UI Server version.

In case of any problem with new version, need to Stop service, please follow (step 3), revert to backed up files (step 4) and restart service (step 6).

52
Purpose: To run the Liquid UI Server with Domain User Account.

Pre-requisites:
Liquid UI Server with Valid License.
To Know how to Install the Liquid UI Server, Please follow the below Article.
http://www.guixt.com/forum/index.php/topic,400.0.html

Please follow the steps below:

1. Navigate to Services window.
      - Enter "Services.msc" in the Search Bar of the machine and hit Enter.

2. "Services" Window will Pop-up, Select the "Synactive R/3 Proxy", do a right click and Select the Properties from the options ribbon.

3. "Synactive R/3 Proxy Properties" window will Pop-up.

4. STOP Liquid UI Server service, click on "Stop" button.

5.  Goto the "Logon" Tab.

6. Select "This Account" radio button and Specify the Domain User Account Login Credentials and click "Apply" and then "OK"

7. START Liquid UI Server service, click on "Start" button.

Refer to the Attachment for Clarity.....
53
Purpose : To resolve the issue concerning Liquid UI Server didn't start shows "Error in Binding socket.(Error=10048) (ErrorNum=0)".

Please follow the below Steps:

1. Navigate to Services window.
      - Enter "Services.msc" in the Search Bar of the machine and hit Enter.

2. "Services" Window will Pop-up, Select the "Synactive R/3 Proxy", do a right click and Select the Properties from the options ribbon.

3. "Synactive R/3 Proxy Properties" window will Pop-up.

4. STOP Liquid UI Server service, click on "Stop" button.

5. Open the Task manager and check, it should be only one Liquid UI Server task running in the background.

6. Now Restart the Liquid UI Server by opening the "ConsleMode.bat" file, it will start the Liquid UI Server successfully.

Note:
Don't Stop the Synactive R/3 proxy on Production Servers as it will disconnect the users from using the Liquid UI Server Service

Refer to the Attachment for Clarity....
54
Purpose:
To resolve issue concerning Liquid UI Designer WYSIWYG window displaying black screen.

Pre-requisites:

1. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not.
https://www.guixt.com/forum/index.php/topic,437.0.html

Please follow the below Steps:

1. Launch the Liquid UI Designer.

2. On the Menu Bar click on EDIT, and then click on Options.

3. A window will Pop-up, click on the "Compatibility Modes" Tab.

4. In GuiXT Designer modes select "Compatible with Blue Crystal Design", click on Apply and then click on OK.


Refer to the Attachment for further Reference....
55
Purpose: To resolve issue concerning Liquid UI Designer script not reflecting on SAP GUI Screen.

Pre-requisites:

1. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not.
https://www.guixt.com/forum/index.php/topic,437.0.html

2. Liquid UI Designer Product Valid License
To Request for a License or to the Check the validity Refer to the below article.
https://www.guixt.com/forum/index.php/topic,228.0.html

Below are the steps to follow:
Step1:
Locate guixt.sjs file
It can be found in SAP GUI Installed folder on the Local machine.
C:\Program Files\SAP\FrontEnd\SAPgui         --> 32bit O.S
C:\Program Files(x86)\SAP\FrontEnd\SAPgui --> 64bit O.S

Step2:
Specify the directory path
The directory path is the path, in which the LUI Script will get saved and gets executed, make sure to specify the correct path.

Example:
If the LUI Script needs to be stored in the path "C:\\LiquidUI\\scripts";
then specify as below
directory1="C:\\LiquidUI\\scripts";

Step3:
Open the Liquid UI Designer, And on the Menu bar click on DIRECTORIES and verify whether the directory is set or not.
if it is not set then On the Menu bar click on the File and click on the "Save As" button.
Specify the directory path, select the Directory radio button and click on the Save button.


Refer to the Attachment for Clarity....
56
Purpose:
To enable Cornelius/Debug window, on Liquid UI Desktop.

Pre-requisites:

1. Liquid UI Desktop should be Installed.
Refer to the below Article to Know the Installation of Liquid UI Desktop.
https://www.guixt.com/forum/index.php/topic,204.0.html

2. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not
https://www.guixt.com/forum/index.php/topic,437.0.html

3. All SAP Gui Sessions needs to be closed including the Logon Pad before making any changes.
 
Note:
Highly Recommend to be used only when developing and debugging Liquid UI Scripts, and not for business users.

Below are the steps to Follow:
Step 01: Location of the "guixt.sjs" file:
guixt.sjs file can be found in SAP GUI Installed folder on the Local machine.
   C:\Program Files\SAP\FrontEnd\SAPgui         --> 32bit O.S
   C:\Program Files(x86)\SAP\FrontEnd\SAPgui --> 64bit O.S

Step 02: Changes to be incorporated in the guixt.sjs file:
Debug window flags:

OPENCONSOLE=0x00008000;         // Display Cornelius Window
HIDECONSOLE=0x00000000;         // Hide Cornelius Window
TRACE_RFCCALL=0x10000000;         // RFC Trace Flags

To Open the Console (Cornelius or Debugging Window) set the TRACEFLAGS as below.
TRACEFLAGS=OPENCONSOLE;

To Hide the Console (Cornelius or Debugging Window) set the TRACEFLAGS as below.
TRACEFLAGS=HIDECONSOLE;

To Look through the RFC Traffic in the Console set the TRACE_RFCCALL as below.
TRACE_RFCCALL=0x10000000;   

Set the TRACEFLAG as Shown Below:
TRACEFLAGS=OPENCONSOLE;

And Restart the SAPGui and Login to your SAP Server, it will Pop-up the Cornelius window which would look like as "Command Prompt".


Refer to the Attachment for Clarity....
57
Purpose:

To move the cursor to the desired field when a Tab is Pressed.

Syntax:

tab("[From-Screen-Field]","[To-Screen-Field]");

Example: Below example, explains the navigation of "Cursor", when a tab is performed, with Liquid UI script tab command defined.

when a tab is performed, while cursor is stationed in "PO date" inputfield, the cursor focus moves to "Deliver.Plant" inputfield and then when the tab is performed again from "Deliver.Plant" inputfield cursor focus is moved to "Payment Card" inputfield.
Then again when the tab is performed, when the cursor focus is on "Card Verif.Code" inputfield, the cursor focus shifts to "All Items Table Item Column First Row".


1. Create a script file "SAPMV45A.E4001.sjs" with the following code and save it in your ws scripts directory as configured in "guixt.sjs" file.

       tab("F[PO date]","F[Deliver.Plant]");
       tab("F[Deliver.Plant]","F[Payment Card]");
       tab("F[Card Verif.Code]","cell[All items,Item,1]");


2. Navigate to the transaction VA01. Input "Order type" as "OR" and hit enter.
3. Set cursor focus on "PO date" field, by clicking inside the inputfield, now press "Tab" on the keyboard, now the cursor moves to the "Deliver.Plant" inputfield, when the Tab is pressed again, the cursor will move from "Deliver.Plant" inputfield to "Payment terms" inputfield.
And so, when the Tab is Pressed while cursor focus is on "Card Verif.Code" inputfield the cursor will move to the "All Items Table Item column First row".
58
WS aka Web Scripts (Attended RPA for SAP) / OnTCodeTerminate Event Handler.
« Last post by Ashfaq Ahmed on July 06, 2020, 02:37:34 AM »
Purpose:
OnTCodeTerminate is an Event Handler, which will trigger a function when an Exit Button is clicked/tapped from the transaction.

Syntax:
onTCodeTerminate[_transaction] = function(){
//Statements
-----------------;
-----------------;
}

Note:
OnTcodeTerminate Event Handler does not take any options.

Example:
Below example, executes the function, which resets the variable, on exiting the transaction.

Following are the Steps:

1. Create a script file "SAPMV45A.E0100.SJS" with the below code and save it in your WS scripts directory as configured in "guixt.sjs" file.

LIQUID UI script: SAPMV45A.E0100.SJS

VA01: Screen script
set("V[z_variable1]" , "1000"); //Initializing the variables
set("V[z_variable2]" , "2000");
println ("-----------Value of z_variable1 before clicking Exit Button is : " +z_variable1);
println ("-----------Value of z_variable2 before clicking Exit Button is : " +z_variable2);

onTCodeTerminate executing function
onTCodeTerminate[_transaction] = function (){
   set("V[z_*]",""); //Resetting the Variables
   message ("S: Variables are resetted");
   println ("-----------Value of z_variable1 after clicking Exit Button is : " +z_variable1);
   println ("-----------Value of z_variable2 after clicking Exit Button is : " +z_variable2);
}

Refer to the Attachment for Clarity...
59
The requirement is to display/change screen title during long function processing, when automating multiple screens

When the processing time exceeds few seconds, users becomes impatient, as well have the perception that the system is slow.
It makes sense in these scenarios, to indicate clearly that the system is carrying out substantial amount of task and therefore user needs to wait for the action to be completed.

With the use of title command, a suitable message can be displayed to the user during auto processing.
The title can be changed multiple times within each onscreen block and/or steps for a long running function.

Example

function testFunction() {

onscreen 'SAPLSMTR_NAVIGATION.0100'
   title("Reading Notification Data.. Please Wait..."
   enter('/niw23');

onscreen 'SAPLIQS0.0100'
   title("Navigation to Notification Screen.. Please Wait..."
   set('F[Notification]','10001291');
   enter();

}

60
The requirement is to call the transaction and skip the initial screen by setting fixed values into the initial screen of the transaction
This is possible with a function attached to a pushbutton.
But in simple cases there is an alternate method, by using a SAP GUI built-in feature which allows specifying field values as part of the OK code

Examples:

1. Executes in same session
pushbutton([TOOLBAR],'Create Work Order (IW31)','/*IW31 AUFPAR-PM_AUFART=PM02; CAUFVD-IWERK=1000');

2. Executes in a new session
pushbutton([TOOLBAR],'Create Work Order (IW31)','/O*IW31 AUFPAR-PM_AUFART=PM02; CAUFVD-IWERK=1000');

Pages: 1 ... 4 5 [6] 7 8 ... 10