Recent Posts

Pages: 1 ... 5 6 [7] 8 9 10
61
The requirement is to call the transaction and skip the initial screen by setting fixed values into the initial screen of the transaction
This is possible with a function attached to a pushbutton.
But in simple cases there is an alternate method, by using a SAP GUI built-in feature which allows specifying field values as part of the OK code

Examples:

1. Executes in same session
pushbutton([TOOLBAR],'Create Work Order (IW31)','/*IW31 AUFPAR-PM_AUFART=PM02; CAUFVD-IWERK=1000');

2. Executes in a new session
pushbutton([TOOLBAR],'Create Work Order (IW31)','/O*IW31 AUFPAR-PM_AUFART=PM02; CAUFVD-IWERK=1000');

62
Mobile Products (Android, iOS and CE) / Context Menu on Liquid UI Client.
« Last post by Ashfaq Ahmed on June 04, 2020, 02:47:10 AM »
Purpose:
To Pop-up "Context Menu" on Liquid UI Client (Liquid UI Android, Liquid UI iOS).
   -Usage of Context Menu to Navigate between Pages on a Print Preview Screen.

Action to display Context Menu:
Long Tap on the Screen, pop up of Context Menu, would be displayed.

Example:
Page Navigation on Liquid UI Client App using "Context Menu".

Below are the steps:
1. Navigate to Transaction "ME29N".
2. Click on the "Print Preview" Button, the screen navigates to the Printable Purchase Order Document.
3. Long Tap on the Screen, "Context Menu" is displayed.
    - Scroll down to see the Navigation Options First Page, Previous Page, Next Page, Last Page.



Refer to the Attachment for Clarity....
63
Purpose:  Navigate to Desired transaction on click of a pushbutton with scanning functionality.

Pre-requisites:
1.Liquid UI Server Configuration,
2. Liquid UI Android version 3.0.7.0 or later.
3. Liquid UI sample Script (Script is attached to this article).


****************************************************************************************
SAMPLE WORKING SCRIPT:
The sample script is on the SAP Easy Access screen (SAPLSMTR_NAVIGATION.E0100.sjs).

del("X[IMAGE_CONTAINER]");
inputfield([1,0],"Test field",[2,0],{"name":"z_stdBrcd","size":37});
pushbutton([3,20], "@5M@Scan Barcode", "/_gala_scan,MM01,z_stdBrcd", {"size":[1,14]});

/gala_scan - Used to get the Scanner to open.
MM01 - the transaction to the user to navigate.
z_stdbrcd - the variable to the Input field.


****************************************************************************************
Example:
1. Launch Liquid UI Client App.
2. Utilize the Connection of your Liquid UI Server connection created to SAP server.
3. SAP Easy Access will appear, with Liquid UI pushbutton "SCAN BARCODE" and an input field "Test field".
4. Click on the "SCAN BARCODE" push button, the device's camera will open to scan the QR code/Barcode.
5. Scan the code, after a successful scan, the user will be navigated to the transaction as per the desired transaction given below.
              pushbutton ([3,20], "@5M@Scan Barcode", "/_gala_scan, MM01, z_stdBrcd", {"size": [1,14]});

Result:
1.User is navigated to MM01 initial screen.
2.The scanned value will be populated into the variable in the SAP Easy Access screen.




Refer to the attachment for further reference....







64
Purpose:

To Incorporate Beep Sound using LUI Script in Liquid UI Android, Mobile.

Example:

In the Below Example Implementing the Notify Bell Signal in VA01 Create Sales Order: Initial Screen in that when the User Left's the Order Type, Sales Organization Input field as Blank and tries to Navigates to the Next Screen it will Notify the User with Beep Sound.

Steps:

1. Create a script file "SAPMV45A.E0101.sjs" with the following code and save it in your WS scripts directory as configured in "guixt.sjs" file.

///////////////////////////////SAPMV45A.E0101.SJS///////////////////////////////

load('stringFunctions.sjs'); // Loading the stringFunctions.

text([0,20], "&V[G_RF_BEEP]");

// Function isBlank is used to check for blank string.
// Specifically used to determine if input exist in the edit field
.

function isBlank(strInput) {
   var strVal = getString(strInput);
   var blank = strVal == "";
   return blank;
}

function fn_belltest() {
set("V[z_order]","&F[Order Type]");
set("V[z_salesorg]","&F[Sales Organization]");
set("V[G_RF_BEEP]" ,"");

   if(isBlank(z_order) || z_order==undefined || z_order=="?" ){
      set("V[G_RF_BEEP]" ,"");      // Beep 1 Time.
       return ("E: Enter Order Type");
   }

   else if(isBlank(z_salesorg)) {
      set("V[G_RF_BEEP]" ,"");     //Beep 2 Times.
       return ("E: Enter Sales Organization");
   }
enter();
}
onUIEvents["Enter"]={"process":fn_belltest};


Refer to the Attachment for Clarity....
 

65
WS aka Web Scripts (Attended RPA for SAP) / Implementation of onmessage
« Last post by Ashfaq Ahmed on January 30, 2020, 10:54:02 PM »
   Purpose:

   
  • > To do error handling and correctly redirecting the error messages, System messages to the Respective screen.
  • > Used to Capture SAP messages.

   Syntax:

                            onscreen 'SAPSCREEN'
                       enter ();
                               onmessage
                                ----------------
                                ----------------

                               enter ();


   
  • Before going further, we need to know the working of goto label in order to Implement onmessage.

   goto-label:
   goto label is used for altering the program flow in Liquid UI.

   Syntax:

                           goto labelname;
                          ---------------------
                           ---------------------

                          labelname:
                          ---------------------
                           ---------------------

   Note:

   •   onmessage should be used after the onscreen/enter block.

   •   An Action is Needed to Exit out of the onmessage block   


   Example:
   Below is the Example that Illustrates the Usage of onmessage.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
   onscreen 'SAPLIQS0.0100'

   set('F[Notification type]','&V[z_zguixt_notif]'); // Notification Type

   enter();

   onscreen 'SAPLIQS0.0100'

   set('F[Functional loc.]','&V[z_Functionalloc]'); //Functional Location

   set('F[VIQMEL-QMDAT]', '&V[z_date]');  //Date
      
   enter();

   onmessage

      if (_message. substring(0,2)=='E:') {  --------------------------------------------->If Error found then do the following

      set('F[Functional loc.]',''); ----------------------------------------------------------->Setting the value to Empty

      set('F[VIQMEL-QMDAT]',''); ---------------------------------------------------------->Setting the value to Empty

      message(_message); ---------------------------------------------------------------->Displaying the Message

      enter();

      goto SCRIPT_END;-------------------------------------------------------------------->After Enter go to End of the Function

   }

 else
   {   
     enter();--------------------------------------------------------------------------------->If it is not an Error then continue to the Script
   }
   onscreen 'SAPLIQS0.0100'

   set('F[VIQMEL-QMTXT]', '&V[z_zguixt_Description]');

   enter("=10\\TAB02");

   set('F[Priority]', "&V[z_zguixt_priority]"); //Priority

   enter("=10\\TAB04");

   onscreen ''SAPLSPO1.0500'

   enter("=OPT2");

   set("F[VIQMEL-AUSWK]","&V[z_zguixt_effect]");  //Effect

   enter("/11");    //Save

   SCRIPT_END:;
   }
   



Refer to the Attachment for Clarity.....
66
    Subject:

    Connecting the IOS/Android Devices to LIQUID UI SERVER.

    Note:

    The Following Files need to be configured in Order to Connect to the LIQUID UI SERVER.

    •   "Sapproxy.ini".

    •   "guixt.sjs".

    Steps:

    Following are the Steps that Illustrates the connecting of IOS/Android Devices to LIQUID UI Server.

    Before connecting to LIQUID UI SERVER we need to configure the Following Files.

    Step 1: Configuration of SAPPROXY.INI :
       
    SAPPROXY.INI File Consists of the following
     
    • •   Listenport

    • •   TargetServer

    • •   TargetServerport

    • •   GuixT 10 (Instance Number)


    Step 2: Configuration of "GUIXT.SJS":

    In "GUIXT.SJS" file we need to do the following.

    1. Configuring the Directory path.

    2. Adding Licence.

    3. Setting Trace Flags to Open for Making Cornelius Window Visible.

    Step 3: Starting the LIQUID UI SERVER:

    We can start the LIQUID UI SERVER in mainly two ways

    •   Starting the Synactive R/3 Proxy service
    Services.msc ->Synactive R/3 Proxy->Start

    •   Opening the "Consolemode.bat"
    C:\Program Files (x86) \Liquid UI\LUI Server\ConsoleMode.Bat.

    Note:

    We can start the LIQUIID UI SERVER from any of the way as Shown above.

    Either through the Services.msc or through the "Consolemode.bat"

    we cannot start Both at the same time

    if we do so it will show an Error.

    Solution:

    Open the Services.msc and Stop Synactive R/3 Proxy.
    Services.msc->Synactive R/3 Proxy->Stop.

    Now Start the "ConsoleMode.bat" which can be find as follows.
    C:\Program Files (x86) \Liquid UI\LUI Server\ ConsoleMode.bat.

    Before connecting the Devices to the LIQUID UI SERVER, we need to Edit the Connection Parameters of the Device according to the Machine.

    Such as IP Address, Instance Number, Client, Username, Password and Language etc.


    Following are the Steps:

    Step 1: (Knowing the IP Address of the Machine)

    Open Command Prompt type "ipconfig" and hit Enter.

    Steps 2: (Editing the Connection parameters of the IOS Device)

    1. Open Liquid UI App we can see a list of connections, click on the Arrow Button.

    2. Click on the Edit Button.

    3. Specify the Parameters and click on the "Update Connection Details" Button.



    STEP 4: (Connecting the Device to LIQUID UI SERVER)

    1. First, Start the "LIQUID UI SERVER" from "ConsoleMode.bat" which can be found below

        C:\Program Files (x86) \Liquid UI\LUI Server\ConsoleMode.bat.

    2. Open the Liquid UI App and Click on the Connect Button.

    3. It will Successfully get connected to the LIQUID UI SERVER.

    4. Follow the same steps for connecting Android to LIQUID UI SERVER.

    Refer to the Attachment for Clarity......


    67
    Mobile Products (Android, iOS and CE) / Changing Themes in LIQUID UI IOS
    « Last post by Ashfaq Ahmed on December 17, 2019, 04:01:55 AM »
    Purpose:

    To Change the theme On LIQUID UI IOS.

    Steps:

    1. Open Liquid UI App.

    2. On the right Bottom Corner of your screen Click on the Server Connection.

    3. Click on the Theme Selection Option.

    4. "Theme Selection window" will Pop-up, Select the Theme and Click Ok.


    Refer to the Attachment for Clarity.......
    68
    Mobile Products (Android, iOS and CE) / Language Localization
    « Last post by Saisree Paluri on December 16, 2019, 10:34:35 PM »
    Purpose: To allow users change the default language of the APP from English to "Korean", "Japanese", "Spanish".

    Example 1 : Changing language before navigating to login Screen.

    Steps for Changing language to Spanish:

    • 1. Navigate to "Edit Connection" for particular server on the server connections screen.

      2. Enter language as "ES" and turn the "Auto Logon" as "ON" and click on "CONNECT TO MY SAP" to update the information.

      3. The profile will be updated successfully. Now click on "CONNECT" for the particular server to Log IN.

      4. The language is now changed to "Spanish".

    Example 1 : Changing language in Login Screen Itself

    Steps:

    • 1. Navigate to "Edit Connection" for particular server on the server connections screen.

      2. Leave language as Optional and turn the "Auto Logon" as "OFF" and click on "CONNECT TO MY SAP" to update the information.

      3. The profile will be updated successfully. Now click on "CONNECT" for the particular server to Log IN.

      4.On the Login screen, enter "ES" for "Logon Language" and Click on "Return".

      5. The language is now changed to "Spanish".

    Note:

    If you are selecting language while logging in, it will be applied to the current session only, and you'll have to enter it again the next time you log in.



    Refer to the attachments for Clarity...

    69
    WS aka Web Scripts (Attended RPA for SAP) / Start Option
    « Last post by Ashfaq Ahmed on December 04, 2019, 04:22:19 AM »
    Purpose:

    • Start Option is used to launch a website or an Application when an image is clicked.

    • With the help of start option we can also run (.bat and .exe Files).

    The Possible Syntaxes is as Follows:

    For Launching Website:

    {"Start:"https://www.guixt.com/"};

    For Launching an Application :

    {"Start:"C://Directory_Name//Filename"};

    Example I:

    Following are the Steps that Illustrate the use of Start option to Launch a website.

    • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
           And add the following code snippet to the file

           image( [1,12], "C:\\LiquidUI\\scripts\\Image.png",{"start":"https://www.guixt.com"});

    • 2. Save the file and Refresh the SAP Screen.

    • 3. Click on the Image a new window will pop up that Launch the website.

    Example II :

    Following are the Steps that Illustrate the use of Start option to Launch an Application.

    • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
           And add the following code snippet to the file

          image("[TOOLBAR]", "C:\\LiquidUI\\scripts\\Designer.png",{ "start":"C:\\LiquidUI\\scripts\\Designer.exe"});

    • 2. Save the file and Refresh the SAP Screen.

    • 3. The Image is Visible on the TOOLBAR as we positioned it to be on the "TOOLBAR".

    • 4. Click on the Image which can be seen on the top right corner of your SAP Screen.

    • 5. It will Launch the Application.


    Refer to the attachments for Clarity...
    70
    Purpose:

    Restrict F4 List for input fields provides a Restrict list of available entry values for a given input field.

     
    Prerequisites:


    • LUI Designer.

      In Place Edit.


    NOTE :

    Files which are necessary for Inplace Edit to work are mentioned Below.

    •   "WSCitation.dll".

    •   "WSEditor.dll".

    These two files should be placed into the "SapGui" Folder, (I.e.) the path "C:\Program Files (x86) \SAP\FrontEnd\SapGui".



     Using IN Place Edit

    The following are the steps that will show the implementation of Restrict F4 List.


    • 1.   Open the SAP EASY Screen and click on the "Liquid UI" Button which can be seen on the top right corner of your SAP screen.

    • 2.   Create an input field by right clicking on the screen, and on the "Create New Element" pop-up. click the inputfield button as shown.

      • 3.   Create another field, double click on it and Fill up the Properties as shown.


      • 3.    Repeat the same steps by creating three more input fields.
                 
                "Distr Chnl" , "Division" and "Sales Office".

      • 5.    After creating the four input fields.

      • 6.    Enter "Sales Org", as "1000" and for the "Distr Chnl" field click on the "searchhelp option" or hit F4 key.
               
               It will Restrict the values and Displays only the "Distr Chnl"values that are associated or comes under the Sales Org "1000".

      • 7.   Enter "Sales Org" as "1000", "Distr Chnl" as "10" and for the "Division" click on the "searchhelp option" or hit F4 key.
               
                It will Restrict the value and Displays only the Divisions that are associated or comes under the Sales Org "1000", Distr Chnl "10".

      • 8.   Enter "Sales Org" as "1000", "Distr Chnl" as "10", "Division"s as "00" and for the Sales Office click on the "searchhelp option" or hit F4 key.
               
                It will Restrict the values and Displays Only Sales Office that are associated or comes under the Sales Org "1000", Distr Chnl "10", Division "00".


      Using LUI Designer.

      Following are the steps that shows the implementation of Restrict F4 List.

      1.  Launch the LUI Designer and Open the SAP Easy Access Screen. (SAPLSMTR_NAVIGATOR.E0100.sjs)

      2.  Create Text, by clicking on the Button as shown.

      3.  Right Click and select the Properties option.

      4.  Name as Sales Org, click Apply and then Ok.

      5.  Create the Input Field by clicking on the Button as Shown.

      6.  Right Click and select the Properties Option.

      7.  Click on the Search Help Tab and Fill Up the Properties as Shown.

      8.  Click Apply and then click on the parameters tab.

      9.  Specify the name of the variable and Click Ok.

      10.  Repeat The same steps by creating three more input fields.
       
             "Distr Chnl", "Division" and "Sales Office".

      11.  Enter  "Sales Org" as "1000", and for the "Dist. Chnl" field click on the "searchhelp button" or hit F4 key.
             
             It will Restrict the values and Displays only the "Distr.Chnl"   values that are associated or comes under the "Sales Org" "1000".

      12.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10" and for the "Division"    click on the "searchhelp button" or hit F4 key.
             
              It will Restrict the value and Displays only the "Divisions"    that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10".

      13.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10", "Division"    as "00" and for the Sales Office click on the "searchhelp button" or hit F4 key.
             
              It will Restrict the values and Displays Only Sales Office that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10", "Division" "00".


      Refer to the Attachments for Clarity......
    Pages: 1 ... 5 6 [7] 8 9 10