Liquid UI Forum

Using Your Liquid UI Products => Web Product and Unattended RPA for SAP => Topic started by: Rahul Gera on May 31, 2017, 01:15:05 PM

Title: SSL Implementation and Configuration of WebServer
Post by: Rahul Gera on May 31, 2017, 01:15:05 PM
Environment:
Liquid UI WebServer Version: 1.1.82.0 and above.

Purpose of SSL in Liquid UI WebServer:
For User to access Liquid UI WebServer  securely.
The SAP application server itself communicates with the Liquid UI WebServer via DIAG so no encryption is required.
To TURN-ON SSL, on Liquid UI WebServer, one Server Certificate, and one Private Key is required.
These Certificate and Key are specified, along with location path in Config.js.

Sample CONFIG.JS:

const USING_SSL = true;                                        // Change the value from 'USING_SSL' from 'false' to 'true'
const DEF_WEBPORTSSL_BASE = "443";
const DEF_WEBPORTSSL_IDX  = "0";
const DEF_SSL_PARAPHRASE  = "Alana888";
const DEF_SSL_KEYFILE     = "server.key";
const DEF_SSL_CERTIFICATE = "server.crt";