Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Rahul Gera on January 25, 2018, 11:44:14 AM

Title: Enabling Screen Modifications on a Pop up screen
Post by: Rahul Gera on January 25, 2018, 11:44:14 AM
Purpose: To Enable Screen Modifications on a pop up screen, when executing in a function.

syntax: enable("executescreenscript");
 
Liquid UI Script:
**********************************************************************
////////////////////////////////// SAPLSMTR_NAVIGATION.E0100 /////////////////////////////////////
**********************************************************************


      onUIEvents['/3']={"fcode":"?","process":backtoHome};
      onUIEvents['/15']={"fcode":"?","process":backtoHome};


**********************************************************************
////////////////////////////////// Input Script (or) Function ///////////////////////////////////////////
**********************************************************************

function backtoHome(){
   
   //Display Equipment : General Data
   onscreen 'SAPLSMTR_NAVIGATION.0100'
   clearscreen();
   enter('/o'); //Overview of Sessions Popup

   onscreen 'RSM04000_ALV_NEW.2000'
   enable("executescreenscript");
   
}


**********************************************************************
////////////////////////////////// RSM04000_ALV_NEW.E2000 /////////////////////////////////////
**********************************************************************
   
   clearscreen();
   title("Exit Transaction?");
   text('P[Cancel]','@02@No');
   text('P[Continue]','@01@Yes');
   text([1,2],"@1A@Changes made would not be saved");
   text([2,6],"Do you want to exit?");
   windowsize([3,3,55,8]);