Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Saisree Paluri

Pages: [1]
1
Purpose: Achieving Tab functionality using Arrow Keys for an Editable Input Field.
Pre-requisites:  Liquid UI Android version 4.0.8.0 and above

Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. For Example, navigate to VA01 Transaction and Tap on Right arrow Key on a Qwerty keyboard to navigate to the next Editable input field.
4. Tap on Left Arrow Key on a Qwerty keyboard, it will do a Tab and go to Previous Input Field.


Refer to the Attachment for Clarity....

2
Purpose: To Provide the user the ability to open their SAP transaction documents/files within the application to avoid using any third party application for the same.
Pre-requisites:  Liquid UI Android version 4.21.17.5 and above.
Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. Navigate to IW22 transaction. Tap on the SFO attachment button.
4. In "Services Object" select "Attachment list".
5. On Attachment list screen, select "xlsx" file and tap on the display icon.
 
Result: The User will able to view the "xlsx" file in the file viewer.
 
Note: Inbuilt viewer also supports pdf, docx and images.


Refer to the Attachment for Clarity....

3
Purpose: To help the user to replace the existing value within the input field upon scan.
Pre-requisites: Liquid UI Android version 4.21.16.0 and above.
Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. In "VA02" Transaction, On Screen "Create Sales Order: Initial Screen", long Tap on Input field. Tap on Scan, the device's camera will open to scan the QR code.
4. Scan the code, after a successful scan, Tap on Done.

Result: The Order type "AA" replaced the existing value "OR" in the input control.

Note: This Functionality is supported in Handheld Scan guns.

Refer to the Attachment for Clarity....

4
Mobile Products (Android, iOS and CE) / Dark Mode for Liquid UI Android
« on: January 22, 2021, 02:53:24 AM »
Purpose: To make it easier for the user to use the application in a low-light environment.
Pre-requisites: Liquid UI Android version 4.0.12.2.
Steps:
1. Launch Liquid UI Android App and from the Options Tap on (☰) Menu, Tap on App Settings.
2. For Dark Mode Option, tap on "Always on".
3. Now the Complete Application will change into Dark Mode.

Automatic Option:
1. By enabling the Liquid UI App Dark Mode setting to Automatic. the Liquid UI App takes the Dark mode settings of the Android device and will apply those settings accordingly to itself. This will help the user not to change the Dark mode setting frequently with in the App if the user prefers to have the Dark Mode settings within the device applied to the Liquid UI App automatically.
2. This automatic option is available for Android devices OS version 10 and higher.
3. Launch Liquid UI Android App and from the Options Tap on (☰) Menu, Tap on App Settings.
4. For Dark Mode Option, tap on "Automatic".
5. Use the system setting (Settings -> Display -> Dark mode) to enable Dark mode.

Result: Now the Application will change into dark mode as we choose Automatic.

Note: The text color within the Liquid UI app is set to default as black, then after changing the Dark Mode, the text color will change to white. Similarly, if it is on Red without Dark Mode, after changing to Dark Mode, the text color will become Blue.

To check further how to change the text color within the Liquid UI App, please follow the below article.
https://www.guixt.com/forum/index.php/topic,244.msg248.html#msg248

5
Purpose: To help the user easily make entries into the table/grid controls with the help of UI assist pop up.
Pre-requisites:
• Liquid UI Android version 4.0.11.0,
• Turn ON "UI Assist" on App settings.
Steps:
1.   Launch Liquid UI Android.
2.   Connect to your SAP Server.
3.   Navigate to any transaction. For example, VA01 transaction.
4.   In VA01 Transaction, On Screen "Create Standard Order: Overview", in All items GRID. Long Tap on the first row.
5.   You will get an UI Assist popup which will show the details of all the columns in the grid. Enter the data of columns that you need and tap on "Done".
6.   By taping on Done, the entered data will be updated in the Grid.
7.   If you Tap on Next, you will able to enter the details of the Next available row.
8.   If you Tap on Previous, you will able to navigate back to the previous row where to make the entries.
9.   Enter the data of columns and tap on "Enter".
10. By taping on Enter, the grid data will be executed.



6
Purpose:  Copying the Material Number, Sales Order Number etc., after the successful completion of transaction with the help of Performance Assistant popup.

Steps: 
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. Navigate to any transaction. For example, VA01 transaction.
4. After the transaction is successfully completed, Long Tap on Status Message.
5. You will get a performance Assistant Popup which will show the Order Number. Long Tap on the text to Copy the Order Number. Tap on Copy from the context menu as shown.

Result: You can now Paste the Order number in your Excel Spreadsheet on your mobile device.

Refer to the Attachment for Clarity....



7
Purpose:  To install Liquid UI Android license through .SY9 License file, when you don't have access for the network.

Pre-requisites:  Liquid UI Android version 4.0.4.7 or later.

Request for New License:
1. Launch Liquid UI Client App, Tap on About.
2. Tap on the Synactive ID (SB4308485) to copy the ID to your clipboard as shown.
3. Send us an email to support@guixt.com, with the Synactive ID copied from the device as shown above or contact your AE.

Installation of License using a QR code:
1. After receiving the sy9 license in QR code format upon requesting Liquid UI through email.
2. Launch Liquid UI Client App, Tap on "Request License".
3. Tap on "Apply License" and tap "SCAN LICENSE", the device's camera will open to scan the QR code.
4. After a successful scan, the license will be applied automatically to your Liquid UI Android.


Installation of License using a Scan Gun:
1. Once you tap on "Apply License" and it will navigate to the next screen to add the license key and tap "SCAN LICENSE", point the scanner to scan the QR code.
2. After a successful scan, the license will be applied automatically to your Liquid UI device.


Installation of License using a License Key:
1. Once you tap on "Apply License" and it will navigate to the next screen to add the license key. In the input field, enter the sy9 license key and tap the Submit button.
2. The license will be applied automatically to your Liquid UI Android.


8
Purpose:  Navigate to Desired transaction on click of a pushbutton with scanning functionality.

Pre-requisites:
1.Liquid UI Server Configuration,
2. Liquid UI Android version 3.0.7.0 or later.
3. Liquid UI sample Script (Script is attached to this article).


****************************************************************************************
SAMPLE WORKING SCRIPT:
The sample script is on the SAP Easy Access screen (SAPLSMTR_NAVIGATION.E0100.sjs).

del("X[IMAGE_CONTAINER]");
inputfield([1,0],"Test field",[2,0],{"name":"z_stdBrcd","size":37});
pushbutton([3,20], "@5M@Scan Barcode", "/_gala_scan,MM01,z_stdBrcd", {"size":[1,14]});

/gala_scan - Used to get the Scanner to open.
MM01 - the transaction to the user to navigate.
z_stdbrcd - the variable to the Input field.


****************************************************************************************
Example:
1. Launch Liquid UI Client App.
2. Utilize the Connection of your Liquid UI Server connection created to SAP server.
3. SAP Easy Access will appear, with Liquid UI pushbutton "SCAN BARCODE" and an input field "Test field".
4. Click on the "SCAN BARCODE" push button, the device's camera will open to scan the QR code/Barcode.
5. Scan the code, after a successful scan, the user will be navigated to the transaction as per the desired transaction given below.
              pushbutton ([3,20], "@5M@Scan Barcode", "/_gala_scan, MM01, z_stdBrcd", {"size": [1,14]});

Result:
1.User is navigated to MM01 initial screen.
2.The scanned value will be populated into the variable in the SAP Easy Access screen.




Refer to the attachment for further reference....








9
Mobile Products (Android, iOS and CE) / Language Localization
« on: December 16, 2019, 10:34:35 PM »
Purpose: To allow users change the default language of the APP from English to "Korean", "Japanese", "Spanish".

Example 1 : Changing language before navigating to login Screen.

Steps for Changing language to Spanish:

  • 1. Navigate to "Edit Connection" for particular server on the server connections screen.

    2. Enter language as "ES" and turn the "Auto Logon" as "ON" and click on "CONNECT TO MY SAP" to update the information.

    3. The profile will be updated successfully. Now click on "CONNECT" for the particular server to Log IN.

    4. The language is now changed to "Spanish".

Example 1 : Changing language in Login Screen Itself

Steps:

  • 1. Navigate to "Edit Connection" for particular server on the server connections screen.

    2. Leave language as Optional and turn the "Auto Logon" as "OFF" and click on "CONNECT TO MY SAP" to update the information.

    3. The profile will be updated successfully. Now click on "CONNECT" for the particular server to Log IN.

    4.On the Login screen, enter "ES" for "Logon Language" and Click on "Return".

    5. The language is now changed to "Spanish".

Note:

If you are selecting language while logging in, it will be applied to the current session only, and you'll have to enter it again the next time you log in.



Refer to the attachments for Clarity...


Pages: [1]