Liquid UI Forum

Using Your Liquid UI Products => Developer Toolkit (Designer and Workbench) => Topic started by: Rahul Gera on June 10, 2019, 10:52:44 AM

Title: [TROUBLESHOOT]Error when Importing from Excel
Post by: Rahul Gera on June 10, 2019, 10:52:44 AM
Symptom: Click on Liquid UI Button "Import from Excel", the following error message appears.

"CommonDialog: The common dialog function failed during initialization. This error often occurs when insufficient memory is available".

The Liquid UI Code, that is initiating the commonDialog box is provided below,

    var szPrompt = 'Openrequired File';
    var dialog = new ActiveXObject('MsComDlg.CommonDialog'); 
    dialog.Filter='All Files(*.*)|*.*'; 
    dialog.MaxFileSize=32767; 
    dialog.DialogTitle=szPrompt;
    dialog.Flags=0x200|0x80000|0x800|0x4|0x200000   // Common Dialog Flags More Flags (http://www.guixt.com/forum/index.php/topic,422.0.html)
    dialog.ShowOpen();                                                    // Common Dialog Open Box More Methods (http://www.guixt.com/forum/index.php/topic,422.0.html)
    var ret = dialog.FileName;
    dialog = void 0;