Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - sarvani.kusuri@guixt.com

Pages: [1]
1
GuiXT (Liquid UI) comes bundled with every release of SAP. It provides SAP users with a method to customize SAP screens and transactions without necessitating any ABAP programming. Instead, users can write scripts in JavaScript that will customize SAP, remove unnecessary screens, and simplify the interface. Once you purchase and install a valid WS license in your system, then only you can perform customizations or more advanced tasks, such as combining transactions in SAP. By default, Liquid UI is inactive. To check whether Liquid UI is active or inactive, please do the following:

1. Launch SAP. Press Alt + F12 or click the Customize Local Layout menu icon on the Standard toolbar.






2. You will find various options. Click the Activate GuiXT option.






3. A black check mark will appear in front of the Activate GuiXT option, which indicates that Liquid UI is activated and running successfully.






4. Also, you will find the Cornelius window popped up, which gives us the information on the script execution process. Now, you can execute your Liquid UI scripts successfully.

Note: After installing the Liquid UI for SAP GUI with a valid license, you will need to activate GuiXT in SAP GUI and configure Liquid UI.


2
For the successful implementation of Liquid UI on your SAP GUI, you need to add all the required parameters in the configuration file (guixt.sjs) and then save it. This file is generally present in your SAPgui folder (C:\Program Files (x86)\SAP\FrontEnd\SAPgui). You need to add your scripts directory path in your guixt.sjs file for executing Liquid UI scripts.

Defining a directory path in the configuration file helps SAP GUI to find the location of script files used for customizing the SAP screens. SAP screens are customized as per the WS script added in the screen script file.

In the guixt.sjs file, you can define various Liquid UI parameters to work on the WS scripts. You can specify a maximum of four script directory paths in the configuration file, and the Liquid UI will consider the script directory in the sequential order. The script directory paths can be either local, network, HTTP, FTP, or SAP web repository.

Script directories:
Here you can see how to define the directory path of scripts.

Local directory:
Code: [Select]
directory1= "C:\\LiquidUI\\scripts";
Network directory:
Code: [Select]
directory2 = "\\\\server\\directoryName";
Web directory:
Code: [Select]
directory3 = "http://server//directoryName";
FTP directory:
Code: [Select]
directory4 = "ftp://server//directoryName";
SAP Web Repository:
Code: [Select]
directory4 = "sapwr:z.LiquidUI.demo";



3
Liquid UI for SAP GUI is a license-based software. After installation, you need a valid license for the Liquid UI WS to run successfully. You can request a Liquid UI for SAP GUI/WS license by sending an email to Synactive at rfi@guixt.com. The WS license is typically issued for a year and must remain valid to receive updates.

Note: Although the license is not required to install the software, it is required to run the software.

Install license steps:
To install Liquid UI for SAP GUI license, you will need to copy the license key data present in the license file (*.sy3), which was sent to you through an email and paste it in the guixt.sjs file.

The following steps describe the procedure to install a license.

1.  You can request a license by sending an email to Synactive Inc. at rfi@guixt.com.
2.  You will receive a license file in .sy3 file format, as shown like SynactiveIndia-LiquidUI-TRX_TR1_JRX_ID6.sy3.
3.  Open the .sy3 license file in a text editor (such as notepad), you will find the license key details. You will need to copy the license key data (license.push command line) present in the file.




4. Navigate to the SAP GUI Installed folder on the machine. Open the guixt.sjs file present in the SAPgui folder on the machine.
           C:\Program Files\SAP\FrontEnd\SAPgui → 32bit O.S
           C:\Program Files(x86)\SAP\FrontEnd\SAPgui → 64bit O.S




6.  Paste the copied license.push command line from the .sy3 license file into the guixt.sjs file, after "license=[]".




7.  Save your changes and close the guixt.sjs file. If you have moved the guixt.sjs file outside the SAPgui directory to edit, replace the file in the SAPgui directory. The license gets active until the validity date.
Note: To use Liquid UI Web Server, Liquid UI Server, or any other product components together with the Liquid UI for SAP GUI, you must have a valid license for each component. Please see the respective product documentation for instructions on installing a relevant license.

Pages: [1]