Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Ashfaq Ahmed

Pages: 1 [2]
16
Purpose : To resolve the issue concerning Liquid UI Server didn't start shows "Error in Binding socket.(Error=10048) (ErrorNum=0)".

Please follow the below Steps:

1. Navigate to Services window.
      - Enter "Services.msc" in the Search Bar of the machine and hit Enter.

2. "Services" Window will Pop-up, Select the "Synactive R/3 Proxy", do a right click and Select the Properties from the options ribbon.

3. "Synactive R/3 Proxy Properties" window will Pop-up.

4. STOP Liquid UI Server service, click on "Stop" button.

5. Open the Task manager and check, it should be only one Liquid UI Server task running in the background.

6. Now Restart the Liquid UI Server by opening the "ConsleMode.bat" file, it will start the Liquid UI Server successfully.

Note:
Don't Stop the Synactive R/3 proxy on Production Servers as it will disconnect the users from using the Liquid UI Server Service

Refer to the Attachment for Clarity....

17
Purpose:
To resolve issue concerning Liquid UI Designer WYSIWYG window displaying black screen.

Pre-requisites:

1. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not.
https://www.guixt.com/forum/index.php/topic,437.0.html

Please follow the below Steps:

1. Launch the Liquid UI Designer.

2. On the Menu Bar click on EDIT, and then click on Options.

3. A window will Pop-up, click on the "Compatibility Modes" Tab.

4. In GuiXT Designer modes select "Compatible with Blue Crystal Design", click on Apply and then click on OK.


Refer to the Attachment for further Reference....

18
Purpose: To resolve issue concerning Liquid UI Designer script not reflecting on SAP GUI Screen.

Pre-requisites:

1. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not.
https://www.guixt.com/forum/index.php/topic,437.0.html

2. Liquid UI Designer Product Valid License
To Request for a License or to the Check the validity Refer to the below article.
https://www.guixt.com/forum/index.php/topic,228.0.html

Below are the steps to follow:
Step1:
Locate guixt.sjs file
It can be found in SAP GUI Installed folder on the Local machine.
C:\Program Files\SAP\FrontEnd\SAPgui         --> 32bit O.S
C:\Program Files(x86)\SAP\FrontEnd\SAPgui --> 64bit O.S

Step2:
Specify the directory path
The directory path is the path, in which the LUI Script will get saved and gets executed, make sure to specify the correct path.

Example:
If the LUI Script needs to be stored in the path "C:\\LiquidUI\\scripts";
then specify as below
directory1="C:\\LiquidUI\\scripts";

Step3:
Open the Liquid UI Designer, And on the Menu bar click on DIRECTORIES and verify whether the directory is set or not.
if it is not set then On the Menu bar click on the File and click on the "Save As" button.
Specify the directory path, select the Directory radio button and click on the Save button.


Refer to the Attachment for Clarity....

19
Purpose:
To enable Cornelius/Debug window, on Liquid UI Desktop.

Pre-requisites:

1. Liquid UI Desktop should be Installed.
Refer to the below Article to Know the Installation of Liquid UI Desktop.
https://www.guixt.com/forum/index.php/topic,204.0.html

2. Liquid UI Activation.
Refer to the below Article, to verify whether Liquid UI is Activated or not
https://www.guixt.com/forum/index.php/topic,437.0.html

3. All SAP Gui Sessions needs to be closed including the Logon Pad before making any changes.
 
Note:
Highly Recommend to be used only when developing and debugging Liquid UI Scripts, and not for business users.

Below are the steps to Follow:
Step 01: Location of the "guixt.sjs" file:
guixt.sjs file can be found in SAP GUI Installed folder on the Local machine.
   C:\Program Files\SAP\FrontEnd\SAPgui         --> 32bit O.S
   C:\Program Files(x86)\SAP\FrontEnd\SAPgui --> 64bit O.S

Step 02: Changes to be incorporated in the guixt.sjs file:
Debug window flags:

OPENCONSOLE=0x00008000;         // Display Cornelius Window
HIDECONSOLE=0x00000000;         // Hide Cornelius Window
TRACE_RFCCALL=0x10000000;         // RFC Trace Flags

To Open the Console (Cornelius or Debugging Window) set the TRACEFLAGS as below.
TRACEFLAGS=OPENCONSOLE;

To Hide the Console (Cornelius or Debugging Window) set the TRACEFLAGS as below.
TRACEFLAGS=HIDECONSOLE;

To Look through the RFC Traffic in the Console set the TRACE_RFCCALL as below.
TRACE_RFCCALL=0x10000000;   

Set the TRACEFLAG as Shown Below:
TRACEFLAGS=OPENCONSOLE;

And Restart the SAPGui and Login to your SAP Server, it will Pop-up the Cornelius window which would look like as "Command Prompt".


Refer to the Attachment for Clarity....

20
Purpose:

To move the cursor to the desired field when a Tab is Pressed.

Syntax:

tab("[From-Screen-Field]","[To-Screen-Field]");

Example: Below example, explains the navigation of "Cursor", when a tab is performed, with Liquid UI script tab command defined.

when a tab is performed, while cursor is stationed in "PO date" inputfield, the cursor focus moves to "Deliver.Plant" inputfield and then when the tab is performed again from "Deliver.Plant" inputfield cursor focus is moved to "Payment Card" inputfield.
Then again when the tab is performed, when the cursor focus is on "Card Verif.Code" inputfield, the cursor focus shifts to "All Items Table Item Column First Row".


1. Create a script file "SAPMV45A.E4001.sjs" with the following code and save it in your ws scripts directory as configured in "guixt.sjs" file.

       tab("F[PO date]","F[Deliver.Plant]");
       tab("F[Deliver.Plant]","F[Payment Card]");
       tab("F[Card Verif.Code]","cell[All items,Item,1]");


2. Navigate to the transaction VA01. Input "Order type" as "OR" and hit enter.
3. Set cursor focus on "PO date" field, by clicking inside the inputfield, now press "Tab" on the keyboard, now the cursor moves to the "Deliver.Plant" inputfield, when the Tab is pressed again, the cursor will move from "Deliver.Plant" inputfield to "Payment terms" inputfield.
And so, when the Tab is Pressed while cursor focus is on "Card Verif.Code" inputfield the cursor will move to the "All Items Table Item column First row".

21
Purpose:
OnTCodeTerminate is an Event Handler, which will trigger a function when an Exit Button is clicked/tapped from the transaction.

Syntax:
onTCodeTerminate[_transaction] = function(){
//Statements
-----------------;
-----------------;
}

Note:
OnTcodeTerminate Event Handler does not take any options.

Example:
Below example, executes the function, which resets the variable, on exiting the transaction.

Following are the Steps:

1. Create a script file "SAPMV45A.E0100.SJS" with the below code and save it in your WS scripts directory as configured in "guixt.sjs" file.

LIQUID UI script: SAPMV45A.E0100.SJS

VA01: Screen script
set("V[z_variable1]" , "1000"); //Initializing the variables
set("V[z_variable2]" , "2000");
println ("-----------Value of z_variable1 before clicking Exit Button is : " +z_variable1);
println ("-----------Value of z_variable2 before clicking Exit Button is : " +z_variable2);

onTCodeTerminate executing function
onTCodeTerminate[_transaction] = function (){
   set("V[z_*]",""); //Resetting the Variables
   message ("S: Variables are resetted");
   println ("-----------Value of z_variable1 after clicking Exit Button is : " +z_variable1);
   println ("-----------Value of z_variable2 after clicking Exit Button is : " +z_variable2);
}

Refer to the Attachment for Clarity...

22
Purpose:
To Pop-up "Context Menu" on Liquid UI Client (Liquid UI Android, Liquid UI iOS).
   -Usage of Context Menu to Navigate between Pages on a Print Preview Screen.

Action to display Context Menu:
Long Tap on the Screen, pop up of Context Menu, would be displayed.

Example:
Page Navigation on Liquid UI Client App using "Context Menu".

Below are the steps:
1. Navigate to Transaction "ME29N".
2. Click on the "Print Preview" Button, the screen navigates to the Printable Purchase Order Document.
3. Long Tap on the Screen, "Context Menu" is displayed.
    - Scroll down to see the Navigation Options First Page, Previous Page, Next Page, Last Page.



Refer to the Attachment for Clarity....

23
Purpose:

To Incorporate Beep Sound using LUI Script in Liquid UI Android, Mobile.

Example:

In the Below Example Implementing the Notify Bell Signal in VA01 Create Sales Order: Initial Screen in that when the User Left's the Order Type, Sales Organization Input field as Blank and tries to Navigates to the Next Screen it will Notify the User with Beep Sound.

Steps:

1. Create a script file "SAPMV45A.E0101.sjs" with the following code and save it in your WS scripts directory as configured in "guixt.sjs" file.

///////////////////////////////SAPMV45A.E0101.SJS///////////////////////////////

load('stringFunctions.sjs'); // Loading the stringFunctions.

text([0,20], "&V[G_RF_BEEP]");

// Function isBlank is used to check for blank string.
// Specifically used to determine if input exist in the edit field
.

function isBlank(strInput) {
   var strVal = getString(strInput);
   var blank = strVal == "";
   return blank;
}

function fn_belltest() {
set("V[z_order]","&F[Order Type]");
set("V[z_salesorg]","&F[Sales Organization]");
set("V[G_RF_BEEP]" ,"");

   if(isBlank(z_order) || z_order==undefined || z_order=="?" ){
      set("V[G_RF_BEEP]" ,"");      // Beep 1 Time.
       return ("E: Enter Order Type");
   }

   else if(isBlank(z_salesorg)) {
      set("V[G_RF_BEEP]" ,"");     //Beep 2 Times.
       return ("E: Enter Sales Organization");
   }
enter();
}
onUIEvents["Enter"]={"process":fn_belltest};


Refer to the Attachment for Clarity....
 


24
WS aka Web Scripts (Attended RPA for SAP) / Implementation of onmessage
« on: January 30, 2020, 10:54:02 PM »
   Purpose:

   
  • > To do error handling and correctly redirecting the error messages, System messages to the Respective screen.
  • > Used to Capture SAP messages.

   Syntax:

                            onscreen 'SAPSCREEN'
                       enter ();
                               onmessage
                                ----------------
                                ----------------

                               enter ();


   
  • Before going further, we need to know the working of goto label in order to Implement onmessage.

   goto-label:
   goto label is used for altering the program flow in Liquid UI.

   Syntax:

                           goto labelname;
                          ---------------------
                           ---------------------

                          labelname:
                          ---------------------
                           ---------------------

   Note:

   •   onmessage should be used after the onscreen/enter block.

   •   An Action is Needed to Exit out of the onmessage block   


   Example:
   Below is the Example that Illustrates the Usage of onmessage.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
   onscreen 'SAPLIQS0.0100'

   set('F[Notification type]','&V[z_zguixt_notif]'); // Notification Type

   enter();

   onscreen 'SAPLIQS0.0100'

   set('F[Functional loc.]','&V[z_Functionalloc]'); //Functional Location

   set('F[VIQMEL-QMDAT]', '&V[z_date]');  //Date
      
   enter();

   onmessage

      if (_message. substring(0,2)=='E:') {  --------------------------------------------->If Error found then do the following

      set('F[Functional loc.]',''); ----------------------------------------------------------->Setting the value to Empty

      set('F[VIQMEL-QMDAT]',''); ---------------------------------------------------------->Setting the value to Empty

      message(_message); ---------------------------------------------------------------->Displaying the Message

      enter();

      goto SCRIPT_END;-------------------------------------------------------------------->After Enter go to End of the Function

   }

 else
   {   
     enter();--------------------------------------------------------------------------------->If it is not an Error then continue to the Script
   }
   onscreen 'SAPLIQS0.0100'

   set('F[VIQMEL-QMTXT]', '&V[z_zguixt_Description]');

   enter("=10\\TAB02");

   set('F[Priority]', "&V[z_zguixt_priority]"); //Priority

   enter("=10\\TAB04");

   onscreen ''SAPLSPO1.0500'

   enter("=OPT2");

   set("F[VIQMEL-AUSWK]","&V[z_zguixt_effect]");  //Effect

   enter("/11");    //Save

   SCRIPT_END:;
   }
   



Refer to the Attachment for Clarity.....

25
    Subject:

    Connecting the IOS/Android Devices to LIQUID UI SERVER.

    Note:

    The Following Files need to be configured in Order to Connect to the LIQUID UI SERVER.

    •   "Sapproxy.ini".

    •   "guixt.sjs".

    Steps:

    Following are the Steps that Illustrates the connecting of IOS/Android Devices to LIQUID UI Server.

    Before connecting to LIQUID UI SERVER we need to configure the Following Files.

    Step 1: Configuration of SAPPROXY.INI :
       
    SAPPROXY.INI File Consists of the following
     
    • •   Listenport

    • •   TargetServer

    • •   TargetServerport

    • •   GuixT 10 (Instance Number)


    Step 2: Configuration of "GUIXT.SJS":

    In "GUIXT.SJS" file we need to do the following.

    1. Configuring the Directory path.

    2. Adding Licence.

    3. Setting Trace Flags to Open for Making Cornelius Window Visible.

    Step 3: Starting the LIQUID UI SERVER:

    We can start the LIQUID UI SERVER in mainly two ways

    •   Starting the Synactive R/3 Proxy service
    Services.msc ->Synactive R/3 Proxy->Start

    •   Opening the "Consolemode.bat"
    C:\Program Files (x86) \Liquid UI\LUI Server\ConsoleMode.Bat.

    Note:

    We can start the LIQUIID UI SERVER from any of the way as Shown above.

    Either through the Services.msc or through the "Consolemode.bat"

    we cannot start Both at the same time

    if we do so it will show an Error.

    Solution:

    Open the Services.msc and Stop Synactive R/3 Proxy.
    Services.msc->Synactive R/3 Proxy->Stop.

    Now Start the "ConsoleMode.bat" which can be find as follows.
    C:\Program Files (x86) \Liquid UI\LUI Server\ ConsoleMode.bat.

    Before connecting the Devices to the LIQUID UI SERVER, we need to Edit the Connection Parameters of the Device according to the Machine.

    Such as IP Address, Instance Number, Client, Username, Password and Language etc.


    Following are the Steps:

    Step 1: (Knowing the IP Address of the Machine)

    Open Command Prompt type "ipconfig" and hit Enter.

    Steps 2: (Editing the Connection parameters of the IOS Device)

    1. Open Liquid UI App we can see a list of connections, click on the Arrow Button.

    2. Click on the Edit Button.

    3. Specify the Parameters and click on the "Update Connection Details" Button.



    STEP 4: (Connecting the Device to LIQUID UI SERVER)

    1. First, Start the "LIQUID UI SERVER" from "ConsoleMode.bat" which can be found below

        C:\Program Files (x86) \Liquid UI\LUI Server\ConsoleMode.bat.

    2. Open the Liquid UI App and Click on the Connect Button.

    3. It will Successfully get connected to the LIQUID UI SERVER.

    4. Follow the same steps for connecting Android to LIQUID UI SERVER.

    Refer to the Attachment for Clarity......



    26
    Mobile Products (Android, iOS and CE) / Changing Themes in LIQUID UI IOS
    « on: December 17, 2019, 04:01:55 AM »
    Purpose:

    To Change the theme On LIQUID UI IOS.

    Steps:

    1. Open Liquid UI App.

    2. On the right Bottom Corner of your screen Click on the Server Connection.

    3. Click on the Theme Selection Option.

    4. "Theme Selection window" will Pop-up, Select the Theme and Click Ok.


    Refer to the Attachment for Clarity.......

    27
    WS aka Web Scripts (Attended RPA for SAP) / Start Option
    « on: December 04, 2019, 04:22:19 AM »
    Purpose:

    • Start Option is used to launch a website or an Application when an image is clicked.

    • With the help of start option we can also run (.bat and .exe Files).

    The Possible Syntaxes is as Follows:

    For Launching Website:

    {"Start:"https://www.guixt.com/"};

    For Launching an Application :

    {"Start:"C://Directory_Name//Filename"};

    Example I:

    Following are the Steps that Illustrate the use of Start option to Launch a website.

    • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
           And add the following code snippet to the file

           image( [1,12], "C:\\LiquidUI\\scripts\\Image.png",{"start":"https://www.guixt.com"});

    • 2. Save the file and Refresh the SAP Screen.

    • 3. Click on the Image a new window will pop up that Launch the website.

    Example II :

    Following are the Steps that Illustrate the use of Start option to Launch an Application.

    • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
           And add the following code snippet to the file

          image("[TOOLBAR]", "C:\\LiquidUI\\scripts\\Designer.png",{ "start":"C:\\LiquidUI\\scripts\\Designer.exe"});

    • 2. Save the file and Refresh the SAP Screen.

    • 3. The Image is Visible on the TOOLBAR as we positioned it to be on the "TOOLBAR".

    • 4. Click on the Image which can be seen on the top right corner of your SAP Screen.

    • 5. It will Launch the Application.


    Refer to the attachments for Clarity...

    28
    Purpose:

    Restrict F4 List for input fields provides a Restrict list of available entry values for a given input field.

     
    Prerequisites:


    • LUI Designer.

      In Place Edit.


    NOTE :

    Files which are necessary for Inplace Edit to work are mentioned Below.

    •   "WSCitation.dll".

    •   "WSEditor.dll".

    These two files should be placed into the "SapGui" Folder, (I.e.) the path "C:\Program Files (x86) \SAP\FrontEnd\SapGui".



     Using IN Place Edit

    The following are the steps that will show the implementation of Restrict F4 List.


    • 1.   Open the SAP EASY Screen and click on the "Liquid UI" Button which can be seen on the top right corner of your SAP screen.

    • 2.   Create an input field by right clicking on the screen, and on the "Create New Element" pop-up. click the inputfield button as shown.

      • 3.   Create another field, double click on it and Fill up the Properties as shown.


      • 3.    Repeat the same steps by creating three more input fields.
                 
                "Distr Chnl" , "Division" and "Sales Office".

      • 5.    After creating the four input fields.

      • 6.    Enter "Sales Org", as "1000" and for the "Distr Chnl" field click on the "searchhelp option" or hit F4 key.
               
               It will Restrict the values and Displays only the "Distr Chnl"values that are associated or comes under the Sales Org "1000".

      • 7.   Enter "Sales Org" as "1000", "Distr Chnl" as "10" and for the "Division" click on the "searchhelp option" or hit F4 key.
               
                It will Restrict the value and Displays only the Divisions that are associated or comes under the Sales Org "1000", Distr Chnl "10".

      • 8.   Enter "Sales Org" as "1000", "Distr Chnl" as "10", "Division"s as "00" and for the Sales Office click on the "searchhelp option" or hit F4 key.
               
                It will Restrict the values and Displays Only Sales Office that are associated or comes under the Sales Org "1000", Distr Chnl "10", Division "00".


      Using LUI Designer.

      Following are the steps that shows the implementation of Restrict F4 List.

      1.  Launch the LUI Designer and Open the SAP Easy Access Screen. (SAPLSMTR_NAVIGATOR.E0100.sjs)

      2.  Create Text, by clicking on the Button as shown.

      3.  Right Click and select the Properties option.

      4.  Name as Sales Org, click Apply and then Ok.

      5.  Create the Input Field by clicking on the Button as Shown.

      6.  Right Click and select the Properties Option.

      7.  Click on the Search Help Tab and Fill Up the Properties as Shown.

      8.  Click Apply and then click on the parameters tab.

      9.  Specify the name of the variable and Click Ok.

      10.  Repeat The same steps by creating three more input fields.
       
             "Distr Chnl", "Division" and "Sales Office".

      11.  Enter  "Sales Org" as "1000", and for the "Dist. Chnl" field click on the "searchhelp button" or hit F4 key.
             
             It will Restrict the values and Displays only the "Distr.Chnl"   values that are associated or comes under the "Sales Org" "1000".

      12.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10" and for the "Division"    click on the "searchhelp button" or hit F4 key.
             
              It will Restrict the value and Displays only the "Divisions"    that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10".

      13.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10", "Division"    as "00" and for the Sales Office click on the "searchhelp button" or hit F4 key.
             
              It will Restrict the values and Displays Only Sales Office that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10", "Division" "00".


      Refer to the Attachments for Clarity......

    29
    WS aka Web Scripts (Attended RPA for SAP) / columnheader command
    « on: November 04, 2019, 09:53:52 PM »
    Purpose:
     
    To change the column header (COLUMN NAME/LABEL) on a SAP Table.
     
    Syntax:
     
    columnheader("[TableName,ColumnName]", "NewColumnName");
     

    Note:
    1. Does not take any options.
    2. Can only be used on native SAP table columns, it will not work on LIQUID UI table columns.

    Example

    Steps on VA01 Overview screen: The purpose is to change the column name/label "Material" to "Material list" in "All Items" Table.
     
    1.Create a script file "SAPMV45A.E4001.sjs" with the following code and save it in your WS scripts directory as configured in "guixt.sjs" file.
                                 
                                  columnheader("[All items,Material]", "Material List");
     
    2.Navigate to the transaction VA01. Input "Order type" as "OR" and hit enter.
     
    3.You will see that the Column "Material" is changed with "Material list".
     
    Refer to the attachment for further reference....
     

    30
    WS aka Web Scripts (Attended RPA for SAP) / Usage of Leadingspace option
    « on: October 21, 2019, 09:54:50 PM »
    Purpose:

    Leadingspace option retains any spaces that may exist before the character entered in an inputfield.

    Syntax:

    "leadingspace": true

    Example:

    The following are the steps that Illustrate the Implementation of the leadingspace option.

    Steps:

    1.Open the Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
     And add the following code snippet to the file

     Inputfield ([4,1], "Inputfield Test", [4,8], {"name": "Inputfld"," size":26});

    2. Save the File and refresh the SAP screen.
    3.Enter the text  "    Testing" into the inputfield.   (using spaces in-front of the Text)
    4. You can see that it would not retain any spaces.
    5.Now Add leadingspace option as shown below.

       inputfield([4,5], "Inputfield Test", [4,20], {"name":"Inputfld", "size":26,"leadingspace":true});

    6. Save the File and refresh the SAP screen.
    7.Now You can see that it retains the spaces.

    Refer to the attachments for Clarity...

    Pages: 1 [2]