Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: chirag.amin@guixt.com on July 29, 2016, 10:48:37 AM

Title: LiquidUI: System Variable - _database
Post by: chirag.amin@guixt.com on July 29, 2016, 10:48:37 AM
This is a very simple example of using the system variable "_database". This system variable holds a string value of what the name of the database or system ID is. This is useful for when you want to conditionalize scripts based on what system they are in. A script might need to run a certain way for the QAS system versus the PRD system.


LiquidUI Code:

// Depending on what databse is being used
// the title should display differently

if(_database == "TR1"){
   title("Welcome to ZEUS");
}
else if(_database == "TRX"){
   title("Welcome to JUNEAU");
}
else if(_database == "ID7"){
   title("Welcome to ORION");
}