Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: rajesh.sabbineni on August 15, 2016, 12:28:39 PM

Title: LiquidUI-Retryonerror
Post by: rajesh.sabbineni on August 15, 2016, 12:28:39 PM
Upon the appearance of an error message adding delay time option in a loop repeatedly activates the "Enter" button until the error message disappears from the current screen. This is particularly useful in a function  following a modifying or complementary transaction, when you call up a further transaction for which the completion of the current transaction is a necessary condition. The system displays an error message until the required modification has been confirmed.

LiquidUI code:

Note: Declare a variable in esession file to start the delay time in seconds.
DELAY = 20;  // start delay time with 20 seconds

Function:
onscreen 'SAPLIQS0.0100'
   i=0;
   enter("/niw51");
RETRY_DELAY:;      
onerror
   i++;
   delaytime = DELAY*i;
   enter(delaytime);      
   goto RETRY_DELAY;

see attachments..