Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: Benjamin Dasari on June 30, 2017, 03:00:54 PM

Title: [Relative positioning] Change coordinates of screen elements with reference
Post by: Benjamin Dasari on June 30, 2017, 03:00:54 PM
Purpose: Use relative positioning to re-arrange screen elements.
Below example re-arranges "Order type" field relative to position of "Sales Organization" field.
Syntax for 2 different ways of accomplishing relative positioning on VA01 transaction screen.

Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPMV45A.E0101.sjs
----------------------------------------------------------------------------------------------------------------------------------------------

// Syntax 1 - Using Offset Option
pos('F[Order Type]',{"field":"F[Sales Organisation]","offset":[11,1]});

// Syntax 2
pos('F[Order Type]',"F[Sales Organisation]+[11,1]");