Liquid UI Forum

Using Your Liquid UI Products => WS aka Web Scripts (Attended RPA for SAP) => Topic started by: rajesh.sabbineni on April 05, 2016, 02:07:05 PM

Title: Pass values between sessions
Post by: rajesh.sabbineni on April 05, 2016, 02:07:05 PM
Values can be passed between sessions as a parameter by using "using" option.

Note: When you are passing values between sessions. Function should be loaded in esession file since we are opening a new session.

LiquidUI code:
pushbutton([TOOLBAR], "Pass Values", "/oiw31",{"process":open_new_session, "using":{"z_order_type":"PM01" }});

//Initiate functions in esession file
load('functions_iw31.sjs');

// Function to pass the value - functions_iw31.sjs
function open_new_session(param){
   onscreen 'SAPLCOIH.0100'
    set('F[Order Type]', param.z_order_type);
   enter('?');
}

 Refer to below link for more details on using option
http://www.guixt.com/forum/index.php?topic=58.0


see attachments..