GuiXT Mobile offers users the ability to read RFID tags and utilize the information contained therein within SAP transactions. This ability can be used with both Mobile and with the Offline solution when the Mobile client is used in conjunction with that product. Please see the WS Reference Library for a more detailed explanation of how to script RFID reads into your code.
Using RFID requires that you have an additional file witl Mobile. This file is as follows.
The SynRFUI.dll should be installed in the same directory as the other Mobile files.
You also must edit the GuiXTMobile.sy3 file in order to read RFID tags. This edit will depend on the type of device you are using. Currently, we support two different device types for RFID tag reading.
The devices we support are as follows.
To use the Intermac devices, please add the following line to your GuiXTMobile.sy3 file.
RFIDLib=Intermac/EPCC1G2
To use the TransCore devices, please add the following line to your GuiXTMobile.sy3 file.
RFIDLib=TransCore/XXX
The ID following the forward slash specifies the type of tag the user wishes to read. TransCore devices do not require a tag type, so this can be designated with 'XXX' instead of an actual tag type.
A sample GuiXTMobile.sy3 file containing the Intermac RFID entry is shown below:
To read RFID tags with GuiXT Mobile, please do the following.