Parameters and Options

The rfcconnect command takes a number of parameters.

The rfcconnect command can be used to connect with either a Message Server or with an Application Server. In addition, the password can be either in plain text or encrypted. The example string above contains a number of parameters. Some of the parameters are used regardless of whether the RFC connection is being made to a message server or to an application server.

Note: If the password is encrypted, the plain text password will be replaced in the 'PASSWD' parameter by an encrypted string.

Common Parameters

The parameters common to both Message Server and Application Server are as follows:

IFDATABASE
The SAP ERP system that is currently connected. This parameter must be specified in the connection string in order for the connection to occur.
LANG
The default language to be used. 'E' is the language code for English.
CLIENT
The client to which the user is connecting. The standard SAP client is always '000', therefore it is very important to specify which client the user will connect to.
LCHECK
Boolean parameter that signifies if a logon check is performed at time of opening. '0' indicates that no check will be performed; '1' specifies that a check will be performed.
USE_SAP_GUI
Specifies whether the SAP GUI is to be used or not in the relevant connection. Set to '0' if SAP GUI is not to be used; set to '1' if SAP GUI is to be utilized. By default it should be set to '0'.
USER
The username of the RFC user.
PASSWD
The password for the specified RFC user. This can be in two separate formats - either an unencrypted plain text string or an encrypted string.

Message Server

The unique parameters for the Message Server are as follows:

MSHOST
Specifies the SAP Message Server to which the connection is being made.
R3NAME
Specifies the name of the SAP ERP system to which the connection is being made. This is important as the message server needs to know to which specific SAP ERP system it must pass the connection.
GROUP
Specifies the SAP group to which the user belongs.

Please note that if a message server is used, there are also additional parameters that must be included in the message server configuration file. Please see the GuiXT Server documentation for additional information. An example of an rfcconnect statement that includes these parameters is shown below:

rfcConnect="IFDATABASE=XXX,MSHOST=message_server,R3NAME=sap_SYSTEM_NAME, GROUP=group_name, LANG=E,CLIENT=000, SYSNR=00,LCHECK=0,USE_SAP GUI=0,USER=rfc_user, PASSWD=rfc_password";

Application Server

The parameters for the application server are as follows:

ASHOST
Specifies the SAP Message Server to which the connection is being made.
SYSNR
Specifies the name of the SAP ERP system to which the connection is being made. This is important as the message server needs to know to which specific SAP ERP system it must pass the connection.
GROUP
Specifies the SAP group to which the user belongs.

Options

The rfcconnect command does not take any options.