Author Topic: Display Custom Pop-up  (Read 1898 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Display Custom Pop-up
« on: July 29, 2016, 12:03:39 PM »
Purpose:
Display custom pop-up and wait for user interaction.


Liquid UI Code:

// SAPLSMTR_NAVIGATION.E0100.sjs
// User Interface
clearscreen();
pushbutton([1,1], 'Execute Pricing', '/o');

// RSM04000_ALV.E2000.sjs
// Function to execute VK11 when the user clicks 'Yes' on the pop-up
function executeVK11() {
   onscreen 'SAPLSMTR_NAVIGATION.0100'
      enter('/nvk11');
      
   onscreen 'SAPMV13A.0100'
      set('F[Condition type]','PR00');
      enter();

   onscreen 'SAPLV14A.0100'
      enter();
}

// Pop-up screen Interface
clearscreen();
title('Decision to Proceed');
text([2,2], 'Do you want to create pricing conditions?');
text([3,2], 'Press <Yes> to continue, Press <No> to stop');
del('P[Generate]');
del('P[End Session]');
text('P[Continue]','@01@Yes');
text('P[Cancel]','@02@No');

onUIEvents['Enter'] = {"fcode":"/12", "process":executeVK11}
onUIEvents['/12'] = {"fcode":"/12"};


See attachments for code samples!