Author Topic: Retrieve System Message using message type, ID and number  (Read 2490 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Retrieve System Message using message type, ID and number
« on: June 12, 2017, 11:32:41 AM »
Purpose: To retrieve the SAP status message if we know the message Type, ID and Number from SE91 transaction code.

Steps -
Follow the below steps in order to retrieve the message-
1.   Navigate to SE91
2.   Table Name: Enter message ID in the Message Class field
3.   In Subobjects, select Messages radio button
4.   In the Number field, enter the message Number
5.   Click Display

This will display the message.
Once we have the message, then we can use indexOf and substring javascript generic functions to perform additional checks, validations, etc.
Ex-
if(_message.substring(0,2)=='E:' &&  _message.indexOf("Invalid Service Order Value")>-1){
     set("V[z_va01_dla_save_err]", "X");
}


Sample Message:

"E: Fill in all required entry fields" - VA01 initial screen, no data filled out, hit Enter

In SE91:

the Message Class is "00"
the Number is "55"
« Last Edit: August 11, 2017, 03:26:41 PM by chirag.amin@guixt.com »