Author Topic: Adding Time Delay in a process/function  (Read 3113 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Adding Time Delay in a process/function
« on: June 12, 2017, 02:00:28 PM »
Purpose: We can cause a delay specified in milliseconds before executing an enter command.
This might be required in cases where the screen displays a status message specifying that it is locked by the current user or if we would like to wait for certain time before executing an action.

In the below example, Enter is performed after the specified number of milliseconds. 

Example:

via Liquid UI Desktop -
     enter(3000);           // In this case the action "Enter" is executed after waiting for 3 seconds

     [OR]

     enter("/11",3000);  // In this case the function code "/11" [Save] is executed after waiting for 3 seconds

via Liquid UI Server -
     sleep(3000);           // Waits for 3 seconds before performing the "Enter" action
     enter();

     [OR]

     sleep(3000);           // Waits for 3 seconds before the enter "/11" action
     enter("/11");

« Last Edit: June 12, 2017, 02:05:42 PM by Benjamin Dasari »