Author Topic: Validate SAP screen elements using "isValid" and "isVisible" options  (Read 5522 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Purpose: To check if a SAP screen element exists and is visible or not. Both the options return true or false.

isValid - Can be used to check if a SAP screen element exists or not, i.e., if the control is sent from SAP even though it is not visible on the screen.
Syntax:
if(<"F[GR/GI Slip No.]">.isValid)      // Check if the field exists
     set("V[z_migo_grgislipnum]","X");     


isVisible - Can be used to check if a SAP screen element is visible or not on SAPgui.
Syntax:
if(<"F[GR/GI Slip No.]">.isVisible)   // Check if the field is appears on SAPgui
      set("F[GR/GI Slip No.]", " ");     // Set it to blank

Example-
SAP R/3 - ZEUS [Internal to Synactive]
Inputfield - "GR/GI Slip No."
Transactions MIGO and Z_MIGO for Goods Issue. This field is valid on both the transactions, however only visible in MIGO and not Z_MIGO.

NOTE - Below is the link of another forum article where it is used:
http://www.guixt.com/forum/index.php?topic=81.msg85#msg85
« Last Edit: June 30, 2017, 10:30:00 AM by Benjamin Dasari »