Author Topic: Restrict SAP Menu Item selection  (Read 2204 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Restrict SAP Menu Item selection
« on: June 28, 2017, 02:33:37 PM »
Purpose: Restrict user selection from menu items by deleting/hiding all menu items.

Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPMLSMTR_NAVIGATION.E0100.sjs
----------------------------------------------------------------------------------------------------------------------------------------------
// Function to hide all Menu items on SAP screen
function deleteAllMenuItems() {
   for(i=1;i>0;i++) {
      for(j=1;j>0;j++) {
         if(!<'M['+i+','+j+']'>.isValid)   break;
         del('M['+i+','+j+']');
      }
      j = 1;
      if(!<'M['+i+','+j+']'>.isValid)   break;
   }
}

// Call the function on the screen where the menu items should be hidden/disabled
deleteAllMenuItems();       
« Last Edit: October 02, 2019, 04:08:02 PM by Benjamin Dasari »