Author Topic: [Relative positioning] Change coordinates of screen elements with reference  (Read 1976 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Purpose: Use relative positioning to re-arrange screen elements.
Below example re-arranges "Order type" field relative to position of "Sales Organization" field.
Syntax for 2 different ways of accomplishing relative positioning on VA01 transaction screen.

Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPMV45A.E0101.sjs
----------------------------------------------------------------------------------------------------------------------------------------------

// Syntax 1 - Using Offset Option
pos('F[Order Type]',{"field":"F[Sales Organisation]","offset":[11,1]});

// Syntax 2
pos('F[Order Type]',"F[Sales Organisation]+[11,1]");