Author Topic: Table _tabrow / _tabcol system variables  (Read 1966 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
Table _tabrow / _tabcol system variables
« on: July 06, 2017, 03:28:06 PM »
Purpose:
To identify the cursor position [row,column] if the user has placed the cursor in a table cell.
The system variables "_tabrow" and "_tabcol" can be used to find the cursor position for the row and column, and further to read data from or write data to that position.

For the below example, table displayed in VA01/VA02 transaction.
The cursor position can be identified, when cursor is placed in one of the table cells:

Liquid UI Code:
---------------------------------------------------------------------------------
Script File Name: SAPMV45A.E4001.sjs
---------------------------------------------------------------------------------

pushbutton([TOOLBAR],'Find Position',{'process':readCursorPosition});

function readCursorPosition(){
        // Put cursor in the table cell, to find out its position
        set('V[z_rowcol]','['+_tabrow+','+_tabcol+']');
        println('Value:' + z_rowcol);
}
« Last Edit: July 06, 2017, 03:55:46 PM by Rahul Gera »