Author Topic: Auto Logon on SAPGUI using ELOGON Script File  (Read 3374 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Auto Logon on SAPGUI using ELOGON Script File
« on: September 07, 2017, 10:11:44 AM »
Purpose:
Auto logon to SAP server using "ELOGON.sjs" file.

Usage:
User will be navigated to Easy Access screen as soon as clicked on server connection on "SAP LOGON" pad, eliminating the manual entry of username and password.

Liquid UI Code
///////////////ELOGON.sjs//////////////////////////////

set("F[User]","username"); // sap user name
set("F[Password]","password"); // sap password
enter();

Password can be encrypted and decrypted then assigned to variable which in turn can be passed to "Password" inputfiled with a simple WS function using "RC4 Encryption Algorithm".

Please see below link for more information on encrypting and decrypting the password.
http://www.guixt.com/forum/index.php?topic=241.msg245#msg245