Author Topic: SAP Message system variables in Liquid UI  (Read 1891 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
SAP Message system variables in Liquid UI
« on: September 12, 2017, 11:58:22 AM »
Purpose:
To identify the message number, message type, and message id of the SAP server message.

The system variables "_msgno", "_msgtype" and "_msgid" can be used to find the details of the SAP message, and further to condition Liquid UI scripts.

For the below example, displayed in VA01 transaction.

Liquid UI Code:
---------------------------------------------------------------------------------
Script File Name: SAPMV45A.E4001.sjs
---------------------------------------------------------------------------------


onUIEvents["Enter"]= {'fcode':"/0",'process':z_message};

function z_message()  {
enter();
onerror
   if(_message){
      println("Message: "+_message);
      println("Message Type: "+_msgtype);
      println("Message Number: "+_msgno);
      println("Message ID: "+_msgid);
     }      
  }
« Last Edit: September 12, 2017, 12:23:34 PM by Rahul Gera »