Author Topic: Liquid UI - "text" command  (Read 2016 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Liquid UI - "text" command
« on: September 27, 2017, 04:35:48 PM »
Purpose:
Displays text on a screen.
You can use the text command to perform the following actions:
• Display text on a SAP screen
• Change the name of any of the following SAP elements:
• checkbox
• context menus
• inputfield
• pushbutton
• radiobutton
• tab


Syntax:
text([row_number,col_number], "Text Label",{option:"optionvalue"});
- Adds text to a SAP screen.
- The row and column number specify the location on the screen where the text will appear.

var z_txt = "text"; text([rows, cols],+z_txt);
- Adds text to a SAP screen from a variable.

text("C[checkboxName]", "New Name");
- Changes a checkbox's name.

text("F[fieldName]", "New Name");
- Changes an inputfield's name.

text("O[optionMenu_label]","New option menu label");
text("O[functionKey_label]", "New function key label");
- Changes the label of a context menu or of a function key.

text("P[pushbuttonName]", "New Name");
- Changes a pushbutton's name.

text("R[radiobuttonName]", "New Name");
- Changes a radiobutton's name.

text("T[tabName]", "New Name");
- Changes a tab's name.

   
Options:
The text command takes the following options:

{"comment":true}
Changes both the default font and the default color, resulting in a fixed-font, blue color.

{"fixedfont":true}
Changes the font to a fixed-font.

{"intensified":true}
Changes the text color to blue.

{"left":true}
Draws a line from the text to the nearest screen element to the right of the text.


Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPMV45A.E0101.sjs       // VA01 transaction
----------------------------------------------------------------------------------------------------------------------------------------------
text([12,2], "Custom text added by Liquid UI");
text([13,2], "Custom text with comment option", {"comment":true});
text([14,2], "Custom text with intensified option", {"intensified":true});
text([15,2], "Custom text with left option", {"left":true});

text("F[Order Type]","Order");  // Changes the field name


See attachments for code samples!
« Last Edit: September 27, 2017, 05:29:46 PM by Benjamin Dasari »