Author Topic: Liquid UI - "textbox" command  (Read 2116 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Liquid UI - "textbox" command
« on: September 27, 2017, 05:34:57 PM »
Purpose:
The textbox command creates text fields on a SAP screen.

Syntax:
textbox([startRow, startCol], [endRow, endCol], {"name":"name","option":"option"});
   
Options:
The textbox command takes the following options:

{"readonly":true}
With this option any default text in the textbox cannot be changed by a user.

{"nowordwrap":true}
The text will not wrap.
This option requires users to press 'Enter' to begin a new line.

{"textfont":"font_name"}
Specifies the selected font.
If this option is not specified, defaults to Arial.

{"textheight":x}
Sets the text height in pixels. The default is 16.

{"textweight":x}
Specifies text weight from 1 (thin) to 9 (heavy).
The default standard setting is 5 and the default bold setting is 7.


Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPLSMTR_NAVIGATION.E0100.sjs       // Easy Access
----------------------------------------------------------------------------------------------------------------------------------------------
clearscreen();
var z_text1 = "This is textbox with no options.";
var z_text2 = "This is custom text in textbox with font options.";
copytext({"fromstring":"z_text1","totext":"z_textbox1"});
copytext({"fromstring":"z_text2","totext":"z_textbox2"});
textbox([1,2], [10, 100],{"name":"z_textbox1"});
textbox([11,2], [20, 100],{"name":"z_textbox2", "textfont":"Times", "textweight":8, "textheight":18});


See attachments for code samples!
« Last Edit: October 05, 2017, 11:15:38 AM by Benjamin Dasari »