Author Topic: Liquid UI - "versionnumber" command  (Read 1939 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Liquid UI - "versionnumber" command
« on: September 28, 2017, 02:03:01 PM »
Purpose:
The "versionnumber" command is used principally to reduce web traffic when scripts are hosted in a SAP web repository, a FTP shared directory or a HTTP web share.
In action, the versionnumber command adds a version number to any scripts cached from SAPWR.
If the versionnumber is updated, then SAP will access SAPWR to recache scripts that are stored there.
This version number can be assigned as the user wishes and operates by causing both the logon script and the session script to be loaded each time from the designated script directory.

Syntax:
versionnumber("string", {"option":value});

Note::
For the versionnumber command to function correctly, you must have one of the following two files:
• elogon.sjs
• esession.sjs
   
Options:
{"systemid":"SAP_system_ID"}
If multiple SAP systems with the same name are being employed, users can specify a different system ID.
This system ID is then used to strengthen the cache directory name.

Example::
In the following example, we will demonstrate the versionnumber command in action.

1. Add the following entry to the guixt.sjs file.
directory0 = "C:\\guixt\\versions";
2. Add the following entry to either the "elogon.sjs" or "esession.sjs" files.
versionnumber("000");
3. Now, any time you increment the version number, WS will check the SAPWR directory and download the latest version of the script file.
« Last Edit: October 05, 2017, 11:14:30 AM by Benjamin Dasari »